Says Phone number is invalid on app

Just tried to create a second account just to try says my number isn’t even valid so are the accounts hacked or what?

but never get a code

Please see this thread here for more information on login issues.

As of 5:00 p.m. Pacific, we received word that our 2FA servers have been overloaded by requests and people may have trouble logging in until later. We are working on resolving this issue now.

1 Like

I suggest waiting for a bit. They’ve said that the 2FA service is overloaded at the moment because they globally revoked everyone’s login tokens as a security precaution. Trying over and over again will just make the problem worse, most likely.

I found it weird on my iPhone signed me out automatically, I signed back in thinking maybe it’s a breach tried to set a 2FA no luck I never got the confirmation text.
Signed out and I tried again still no text message but ask me to put the # not sure what’s going on.

Any help

As a security precaution they reset all the login tokens, the 2FA service is just overloaded at the moment with people trying to log in. Give it a bit of time and it will clear up. Further info can be found below

Same issue. Invalid phone number of app.
Other family shared users have no problems.

My Google home says “WYZE HOME IS NT AVAILABLE” i can’t turn on my lights or plugs…

Wyze app says this error. but i dont enter in a number i enter in a email.

1 Like

You’ll need to login to the Wyze app again, and you’ll also need to login to Wyze again through the Google Home app.

1 Like

It wont let me log in and i have 2fa. it jus says invalid number when i put in info

1 Like

Ah, yes. Wyze logged everyone out globally as a security precaution. The 2FA service is overloaded at the moment with everyone trying to login again. Just give it some time and it should work.

i was able to log into my folks account that does not have 2FA ok.

I just had to re-pair/re-sync WYZE to Google Assistant 4 days ago as it then did this WYZE Home is not available thing. I figured it was because i had engaged 2FA and it logged things out.

That’s possible. I’m not sure what happened 4 days ago, but today it’s a global thing. You’ll need to login to Wyze again through Google Home to enable it again.

I can’t even get to the 2FA screen at this point, it just says invalid phone number… I’m using an email not a phone #. :confused:


I was able to relink WYZE HOME to GA, it did not ask for 2FA at all odd.
I still can not log into the WYZE app, so cant view cams or manage devices directly.


SO…i just backed out of the login screen i could not get past…and them there is the WYZE home screen and i can see my things…ummm…what is happening.

EDIT: Closed app again, and now stuck with same issue…

MOD NOTE: Post edited to conform to the Community Guidelines

I wonder if your phone cached a “screenshot” of the app screen, as it looked the last time you opened it. My phone does that sometimes. It will display a recent state of the app for a second, then try to reload it.

So has anybody found a fix for this or should we just wait? I can’t even login says invalid phone number lol…

The fix currently is to ‘just wait’ the service just needs to catch up

1 Like

Well, it was no screen shot, i was able to stream a cam and turn off a plug.
I backed out of app to home screen, the tried to open app and it back to Please enter valid number?

My phone is technically a VOIP classified number (Republic Wireless) but it has always worked before.