Robot vacuum unable to transition between surfaces (cliff sensor issue)

Anyone else have an issue with the robot vacuum not being able to transition from a smooth stone floor to a (very) low rug? I just got mine and on it’s first attempt to vacuum the house (where I used to have an old roomba years ago that worked just fine) it was unable to turn up onto the rug when 1 wheel was on the rug and the other is on the floor. So far much less than thrilled with my purchase.

1 Like

Is the rug thick?

I have a bit of a thick rug in my living room and my WRV sometimes gets stuck in it

Not in the slightest. It’s perhaps 1/3" high effectively no pile.

What color is the rug? If a dark color it may be the cliff sensor thinking it is the edge of something, and when turning it is trying to back away?
My WRV has gotten over some pretty tall thresholds, but I don’t have rugs to compare to.

1 Like

The rug is black at the edges, but it doesn’t approach, stop and turn to avoid. It keeps trying to roll onto it then backs up thinking a wheel is stuck.

Actually there might be something to the cliff sensor theory. I had it clean other rooms where that rug isn’t and it did just fine. Then when returning home where that rug is it seemed to do ok for a bit then started doing back and forths like it was avoiding something.

Is there a way to disable the sensors, or do I just need white tape?

I have read where some put tape and white paper over the sensors if they have no “cliff areas” to worry about.
More here:

There is also a wishlist item to disable this capability. Check it out and give it a vote if you support

Information from Wyze

another community member @nishabe made 3D printed covers for them and shared here


It is in fact the cliff sensors. There are 4 total. The two in the front appear to only be used for sensing cliffs, while the 2 along the sides serve a dual purpose of cliff and wheel off the ground sensing. In placing my reflective material over the sensors to bypass them, I found that you cannot place the reflective material directly on the sensor and instead must put it a bit off of the sensor itself. This is likely due to how the sensor bounces light at a 45 degree angle from the emitter to the sensor in it’s plastic housing.

I ended up using a white piece of paper with clear packing tape over it as my reflective surface and used simple scotch tape to hold them down. I made the pieces large enough to totally cover the entire sensor and taped them so that the sat at an angle from the end of the sensor at the bumper to the main chassis of the robot. This appears to be working.

@WyzeYun @WyzeDave @WyzeDongsheng This is a dumb problem to have. Black accented or very dark rugs/carpets are extremely common place. This should be a very simple fix of bypassing the cliff logic as a setting override. A fix for this should not take more than 15 minutes to implement assuming the cliff logic is a called function, simply add an if statement to the call of the cliff logic and if it is disabled, don’t call it. How this has been a known issue reported by customers for over two years now should be an embarrassment.

1 Like