Return request has not received any response after more than 2 weeks

Hi, I have submitted a return request more than 2 weeks ago, and I even got an email saying that my request is pending and that COVID is delaying the handling of return requests. But it has been more than 2 weeks now and I sent an email reminder once. Still no response. Could you let me know how to proceed? My ticket number is 1055584, thanks.

@WyzeGwendolyn is this something you can help look into?

Welcome to the forums!

I know the returns system is having issues right now. This is the ticker alert on the top of the Support pages:

Our returns system is down. We’re working to resolve this issue ASAP.
The system we use for processing product returns is currently unavailable. We apologize for the inconvenience.

Have you tried calling Supprt and asking? I’ve had good results getting info quick when ive called in. Here is the phone number:
Wyze Support by phone: (206) 339-9646 Available Monday - Friday 5 am - 6 pm PT and Saturday 8 am - 4 pm PT

I’ll send this info up the ladder and see if we can get more info for you, but i am sure the known issue is whats holding this up for you. Sorry about this! Stay tuned…

1 Like

I’m having no response in needing to return one of my orders as well. I have called in and was told they’d look into it and give me a call back with no response as well.

@Omgitstony thanks for letting me know the call number. I just called this morning, and the customer representative sent me an email that looks exactly like what I received and responded 2 weeks ago. I explained that I already responded to an email similar to this, and in fact sent 2 reminders as well. After staying on the line for 25 minutes, he got no response from the person who handled the original ticket, and told me he will follow up through email… So calling on the phone circles back to email, which was the reason I had to call in the first place… Honestly I should have ordered from Amazon, their return process is completely hassle free.

Got a response just now. So calling did work :slight_smile:

1 Like