Can't Update Thermostat Firmware

Just installed my Wyze thermostat and it seems to be working well but I can’t update the firmware from v1.0. I emailed tech support and tried their suggestions (see below). I emailed back that it didn’t work but they never responded. I have app v2.18.18 on an Android phone (also tried it from an Android tablet). Unplugged thermostat and plugged back in to restart it. Logged out of app. Forced stop. Restarted phone. Logged in. Cleared cache. Upgrade keeps failing.

From tech support:

"I am sorry to hear that you’re experiencing issues in using your device through the Wyze app. Don’t worry I’ll help get you through this. Here are some basic troubleshooting steps I’d like you to try.

Important: Make sure to have a stable internet connection.

  1. Ensure the app is up to date. If you’re an Android user, go to Google Play Store and update the latest Wyze app version. If you’re an iOS user, go to the App Store and update the latest Wyze app version.
  2. After the update is finished, log out/log in to the app.
  3. If the issue still persists, force close the Wyze app and restart your device then log in.

I hope these steps help resolve the issue you experienced. If in the event this does not resolve the behavior you can contact us back."

OK, tried the update on an iPad and it worked. Wish they would fix the Android issue though.

So is Wyze going to buy me an iPad to update the thermostat? Fix the problem and allow my android to work. Hoping the firmware update will fix the issues with the thermostat. But Wyze doesn’t seem to want to address and fix the issue.