Beta app to install beta software for Wyze vacuum did not install

I wanted to have access to the beta firmware, so that I could have the second floor on the app. I signed up as a tester, an app update showed up in Google playstore, but when I downloaded it, the app was not the beta one and it indicates that my firmware is up to date (v. 1.6.113) with no second floor option. How would I fix? Thanks.

1 Like

What is the version number of the app you downloaded?

Wyze app Home > Account > About

The current Android WyzeBeta app is v2.20.3.

Once you have the latest beta app installed, add the vacuum project to your testing list. Go to:

Wyze app Home > Account > About > Beta Program > Edit > Wyze Robot Vacuum (check the checkbox) > Save

Vacuum beta firmware 1.6.126 should be available at:

Wyze app Home > Account > Firmware Update


Wyze app Home > your Vacuum > Settings (gear icon upper right) > Device Info > Firmware Version


Thank you! So, there was just one more step that I did not accomplish: From within the app, enroll in the beta program. This fixed it for me. Thanks, again.

1 Like

You’re welcome and glad to hear you got beta going. :+1:

Well, not so fast - half-way there. The Wyze android app that I have is v2.19.15 and not v2.20.3 and no updates to this version are showing up (yet) In playstore.

Go to the Google Play Store and tap on the Wyze app. Do you see notices that Beta signup is in progress?

I do not. In playstore, when I go to Wyze app it reads “Wyze (Beta), You’re a beta tester for this app. Future updates will include beta versions… Last updated Apr 20, 2021.” Again, the version is v2.19.15.

This is what you should see:

It sounds like the Play Store on your phone isn’t updating. Try clearing the app cache for Google Play services and Google Play Store, then restart your phone:

Your phone’s Android settings > Apps > Google Play services > Storage > Clear Cache

Your phone’s Android settings > Apps > Google Play Store > Storage > Clear Cache

1 Like

Sadly, this procedure did not fix issue.

You are definitely set up on your end. You’ll have to wait for Google to provide the app update for your account. Sometimes it takes only minutes after an update is published, sometimes they are so slow it takes days. :expressionless:

Thanks for your help. I will let you know when this update comes my way.

1 Like

I’ll chime in here. I’ve been at this for a week, polling Play Store every 4 hours, and I still don’t have it. I’ve done the clear app cache, reboot sequence 3 times already. And in that time I have received over 100 other app updates from Play Store. Something just isn’t right here. I’ve also contacted the Wyze Team multiple times and sent over several tickets. And it’s just crickets. No one responds.

Same. I’ve reinstalled the app, rechecked the beta tester button for my vacuum, and its still on the production firmware.

I’m having the same trouble. And I have tried both the Android and the iOS app (TestFlight). They both keep showing that my firmware is up-to-date, with the .113. I’ve definitely already enabled the beta within the app.

Same problem here. I’ve updated to the beta app (v2.21.25) via the play store and signed up for the beta program in the app: Wyze app Home > Account > About > Beta Program > Edit > Wyze Robot Vacuum (check the checkbox) > Save

And still, in both the device settings and the app settings, it says that:
Latest Version: 1.6.113

So did both necessary steps, and nada. I waited a day to see if it would work itself out, and nada. Is there something i’m missing?


1 Like

I am also having difficulties getting the firmware to be able to update. I’m enrolled as beta, have current app version and have the wrv checked in the beta section of the app. Still says 1.6.113 is up to date and does not give option to update to 1.6.126.

I asked the support people and the response I got was

“Thanks for your quick response. I’m really sorry but to download the Beta firmware is not possible for now. We don’t have a way to download it manually. The beta firmware for WRV is not given to all beta testers. It is given randomly or by batch. The firmware may be provided to them but we don’t have a timeframe for that.”

Seems a bit odd.


At this point I think it’s safe to say that you won’t be getting beta 1.6.126 if you dont already have it. Support said the same thing to me as they did to @lockgavin. It’s been over a month now since then and no further FW updates have become available.

on reddit there’s threads about this exact issue from several months ago. I reached out to some of the users and they said they still haven’t recieved an update or support didnt give them a clear answer.

Staged rollout is common in development, just in case you release a firmware that bricks devices. You’d rather figure that out on a small set of users than a large set of users. Also helps them manage the support side of thing.

My guess is that we’re not in a group on the backend that has received access to the newer beta and/or it hasn’t been given a wider push for testing - that usually means there’s a lot of bugs being found by the first group that they’re trying to fix before widening the testing sample.

1 Like

thank you Kyle for providing this insight. my main frustration stems from how the beta activation page implies that all users that join the beta will recieve the updated firmware. furthermore.

The initial message relayed to me by support staff was that it was simply an issue with Google Play updating the app and that I would just have to wait. They said this despite having contacted them almost a week after successfully enrolling as a tester, where Google themselves say it would only take a few minutes to enroll and receive the beta application.

Placing a message similar to what you stated would be sufficient and provide transparency to end users. They should make it more clear that beta firmware will only be given to a portion of testers.

1 Like

Yeah, I can agree that the way they’re disseminating information can be a tad confusing for end users. It seems the beta devs and the support team aren’t on the same page. I’ve seen this same issue mentioned a lot on the forums, so I imagine it might cut down on support work if they tweak the Beta Firmware (the one that shows the current version for the robot, etc.) page to reflect that not all users are currently receiving the newer version and availability of it will come at a later time - assuming my hypothesis for why we don’t have it is correct.

Mind you, I don’t work for Wyze, I just have experience in the tech field and how these testing groups usually work.

1 Like