Wyze Plugs blink like they're offline, but all have IP addresses and can be pinged

I’ve got three Wyze plugs that, when plugged in, blink as if they can’t find the Wifi. However, two of them are listed as online in the app while this happens, but I can’t actually do anything with the plugs via the app. It will show me their IP address if I look at the Advanced section in the app, and I can ping the plugs at their IP address. I can also see that there are wireless clients associated with those addresses in the router. But I can’t actually toggle the plugs between on or off, update the firmware, or do anything whatsoever with the plugs from the app. I can use the button on the side to toggle the plug on and off, but the plug will still read “ON” in the app.

I’ve tried resetting and repairing the plugs, but the same thing keeps happening. They’ll connect to my network, they’ll be pingable, but they won’t seem to be actually be online.

Does anyone have any thoughts on what to check on here? The Wifi / internet is working fine for other devices that are on it, and it looks like the Wyze Plugs are connecting to the Wifi just fine as well, but they’re not on the internet for some reason.

1 Like

Welcome to the community @Why

Do you know which version of the plug you have? The 2021 version which will have a key symbol on the back side of the plug (where it plugs into the wall). If not you have the original version.

Can you provide the following;

  • App Version you are using
  • Type of Device being used
  • Firmware of the plug you are experiencing issues with

This issue is being worked on by Wyze. They recently release Beta Firmware which is supposed to correct the issue. I have experienced this myself. Is the Blue Light blinking fast or slow? Fast implies you can pair it again, you don’t need to remove them from the app to pair them.

Also note, the advanced area of the plug will always show the information from when it was last connected. So I would expect to still see the IP Address.

Here is a link to what the Beta Firmware will correct:

All three of the plugs are pre-2021 (no key symbol).

App version: v2.28.0 (102)
Device type: Android
Plug firmware: Two are, one is

I wasn’t aware that the Advanced area always showed the last IP address, so thanks for that information. I do know that the plugs are all still at the addresses listed there, though, because I am able to ping them and see the device connection status in my router.

Regarding the firmware – how will I be able to update the firmware when the devices can’t seem to connect to the internet? Is it possible to update via the wyze_smartplug_apxxx networks?

Edit: I forgot to say, they blink slowly. I can switch them over to blinking quickly by holding the button, and that’s how I repaired a couple of them to troubleshoot. They didn’t work after repairing either, though.

I have this same issue, I went to see if I can return them to Home Depot where I bought them and the reviews there have an obvious shift as of a few weeks ago where every review states the same thing. Thankfully I was able to return mine, guess the whole “stable release” channel is pointless if you’re still going to be paying to beta test their bad firmware.

Well, I guess I’m glad at least that there’s no point in me spending any more time doing troubleshooting. It sounds like it’s an issue present on Wyze’s end and not related to my router or Internet service.

It seems silly that I can’t control the switch locally when on the same network, though. The switch is staying connected to the WiFi, but it’s obviously not connecting to some server somewhere. Why does that prevent me from controlling it when I’m on the same WiFi network as the switch? I can ping the switch from my phone, but I can’t toggle the power state of the switch from my phone. Silly.

1 Like

I see you are still using your “nice words” when it comes to WYZE plugs. You’re a better man than I. :slight_smile:

I’m posting this here as well. The more people that can try this the better. I’m not saying it is a fix, but rather something to try if/when the opportunity presents itself.

Hmm, I’m starting to think that there may also be an application component to this issue. I have my WiFi AP set to reboot every single day at 6:55am. When WYZE plugs work properly they are back online by 6:58AM at the very latest. This morning I watched one of the plugs go bonkers.

Right when the plug should have connected to the WiFi network it instead clicked and started a fast blink for about 10 seconds, then went into a slow blink. To try something new, I decided to restart my Android phone. The plug kept doing the slow blink while my phone was rebooting. Literally as soon as the phone came back up the blue light on my plug stopped blinking.

For the record, my phone was not on my wifi network prior to restarting it nor has it been connected to my wifi network since I restarted it. Please know, this procedure has worked for me once and was performed within 30-seconds of seeing the plug go bonkers. Maybe others can try this if they witness a plug go offline?

I have tried restarting my phone before, but the plugs had always been blinking blue for a very long time. The thing that was different here is I bounced my phone within 30-seconds of seeing the plug go nuts. It is odd that the plug didn’t stop blinking until my phone came all the way up again. This has me thinking a force stop on the app might not do it. The next time I witness a plug go offline I’m bouncing my phone again. If I can repeat the process with the same results I’ll know I’m on to something.

Rebooting my phone when I witnessed another plug go offline this morning didn’t work.

This has already been identified as an issue by Wyze. Please identify your plug if you know it (2021 or earlier), then post a log number here after you experience and issue (Plug > Settings > Wyze Support > Submit a log).

Thanks! :slight_smile:

Why submit more logs if they have already identified this as an issue? Until WYZE pays me or sends me free v3 cams, I’m done being a free production tester! I work in IT and am paid very well for what I do. No more freebies for WYZE!

Furthermore, people have been reporting this issue for MONTHS with logs. How many logs does the dev team freaking need? Unfortunately, the initial beta firmware upgrade they pushed to the beta testers didn’t fix the issue. I suppose if they had 1,000,000 more logs they would have pushed out a beta release that actually fixed the issue? They screwed themselves by introducing the connection logging. Now they can’t remove that functionality and are stuck trying to tame the monster that they created.

Submit more logs…give me a break!

Is there a recommended workaround? I’ve seen suggested tricks for when the plugs work intermittently, but, as it stands, my three pre-2021 plugs don’t work at all. Based on the fact that I can see them connected via my router’s web interface, and the fact that I can ping them, I know they’re connecting to the WiFi network just fine. But that’s all they’ll do is connect to the WiFi network and then slow blink for all eternity.

I’ll submit logs, but I’m not sure how useful they’ll be since nothing seems to be communicating with the plug.

I’ve submitted logs for one of the plugs. Let me know if I should also do the other two.

These plugs still won’t go online. My cameras are still not having any issues, so I don’t think it’s a WiFi / ISP issue. Does anyone know anything else to try here?

I hear that some people that were having issues are no longer having issues since updating to the .179 firmware. With that said, I do not believe that firmware was the fix as it had several reported issues during BETA testing.

There has not been any official word from WYZE since they decided to pull the .179 firmware after also pulling the firmware that they had released prior. The issue has persisted for nearly 2-months now so I sure hope they speak up and let us know what the heck is going on soon.

Meanwhile, I’m going to leave a 1-star review on Amazon to give others the heads up.

I figured this out. In my case, the issue is with Wyze’s incorrect implementation of DNS. As described elsewhere, various Wyze devices have a buggy DNS implementation whereby if your router is using DNS-over-TLS (DoT), the resulting DNS response from the router will be formatted such that Wyze devices cannot interpret the result. These responses are valid, standards-compliant DNS responses, but Wyze devices can’t understand them. This explains why the plugs were on the WiFi but didn’t seem to make it to the Internet.

I switched to another WiFi network that’s not using DoT and the issues resolved.

This seems like an issue Wyze should resolve, though.

1 Like

This worked for me disabled tls over dns on the router & like magic the outdoor smart plug started working. Up to that point I could see it obtain an IP & even update the firmware but not control it from the app.