Wyze Cam v3 - disconnects after setup

I have around 20 wyze cams, so I am familiar with them. Just bought three v3 cams on Amazon. The first two setup easily and super quick. The third camera also did the setup quickly and seemed to have connected and even got a notification that the Alexa skill was enabled for this new camera. I named the camera and the camera was immediately offline. The camera then told me to rescan the QR code. Not sure how to even do that, since I was way past the QR code. I checked my router and the camera was still connected. I tried the whole process again, after unplugging the camera. Same problem. I then updated the firmware via SD card and still same problem.
Tried to call support, but that is a useless exercise.
Went back on Amazon and returned product. Don’t need to deal with this.
Come on Wyze. 33% failure rate and impossible to contact your tech support?

Sounds similar to issues myself and others are having, can only speculate as a fellow user but I believe its a backend issue.