Wyze Cam v2 and Pan Firmware 4.X.7.798 Releasing - 7/21/21

Yeah, There are definitely trails of inconsistent odd behaviors all across these forums. Sorry you’ve got a humdinger there… :expressionless:

I wonder if it stems from the whole dimmed playback issue once they switched to the 64-bit codebase.

Do you ever get IR feedback from dust on the oculus? I know the v2 run 850nm and Pans are 940nm (tactical). 850nm IR is known to emit a faint red glow. Wonder if something’s funky w/your IR emitters.

I’d totally let Wyze replace all or your cams just to say you did.

pink flash issue - usu the IR filter getting stuck and not retracting completely. Then the camera adjusts to the new light level and may get a flare as well.

there’s a hazy, smokey hue and the image isn’t as clear. Believe there is outgassing from the glue used in assembly. There are a few youtube video on how to disassemble and clean.


Does this firmware fix the audio delay of the Wyze cam v2?

Just chiming in here to say this firmware update still doesn’t fix the pink flash / click detection at camera startup that has been going on for the last 2 firmware releases. Get with the program Wyze!!
Like Resist, I’m sick of complaining about this. It’s a super easy fix, and I shouldn’t have to keep rolling back to old firmware just because your support team is too ******* incompetent to fix such a basic issue!

Clearly Wyze hired terrible programmers or their bosses won’t let them spend the time to fix the bugs, because they’re pushing new products instead. Seems like the founders at Wyze just want to increase revenue so they can sell the company.

1 Like

You finally figured this out? The rest of us have know this for a long time. These products are mostly toys, not serious home security products.

Toys aren’t supposed to annoy you to death though, they’re supposed to make you happy. This isn’t making me happy :upside_down_face:


It doesn’t. I have random audio delay still.

solid yellow light. will not reset by itself, or with the sd card.
wyze cam v2
MAC 2C:AA:8E:86:29:C9
i looked for a stock firmware version, but most searches lead to firmware for the android app, not the camera. even if they did, the reset process is not working. i would appreciate your help as soon as possible, as i need to get this camera up and running, as i need it to get people vandalizing property.
i do not prefer one solution over another, aside from whichever solves the problem faster.
thank you for your time and consideration in this matter

Hi John @167294jc and welcome to the community. :slightly_smiling_face:

Am I correct? You have an Android phone with Wyze Application 2.24.23 (September 1, 2021)
and the camera’s firmware was updated to

Now you have a solid yellow light and reset doesn’t work.
Suggest you try download the older f/w to (March 9, 2021) and manual flashing the camera.


  • I did not install this update. I’ll wait for the next version.
  • It installed and everything works.
  • It installed but I had to revert.
  • It bricked my cam and I can’t revert.
  • I have a v2.
  • I have a Pan.

0 voters

My Pan bricked and I tried both the factory reset and flashing versions going back a year, and none brought it back to life. I was sent a replacement camera, which I won’t be updating until I see much more success in the forums.

I’m intrigued by an earlier attempt that held the reset button with a C-clamp for an hour and unbricked a camera. I need to find some suitable hardware to try that.

I’m wondering if there’s a write-protected factory firmware image in the camera or if the factory reset just wipes parameters and uses the last code flashed. If the latter, then there’s no hope if the firmware has an issue with the hardware. I don’t understand how holding the button for an hour would save the device in either case. I’ve tried for up to a minute and it didn’t recover.

1 Like

Well hell, poll’s only been up a day, but now I’m on the fence. Probably should climb back down because ultimately I hate re-aiming these things when I’ve got 'em just so. :slight_smile:

1 Like

Another uncertainty (for me) is whether there will be another firmware version - at least for the v2 which has an able successor in the v3.

Although they’re still selling v2 through HD bundled with Sense Starter Kit, so…

If another v2 version is not released, presumably I will be able to flash the current version through the app any time into the foreseeable future.

Disclosure, my situation is probably not typical, as I have legacy Person Detection (which meets my needs) and an older tablet (which meets my needs) that is now OS excluded by current versions of the Wyze app.


1 Like

New versions out for V2 and Pan :slight_smile:

The link sent me to instructions as to flash a version 3, and I have a V2. Will that matter, or is it the same?

okay. i downloaded what you told me to, and followed the instructions to manually flash the camera. The solid yellow light never changes. no matter how long i hold it down, whether it is before, or after(i tried every combo that i could think of) and it stays yellow. it does make a single click noise , just a few seconds after plugging it in. it sounds similar to the noise you hear when switching the night vision on and off.

Hi @167294jc Yes, the demo_4.9.6.241.bin.zip file is for a Wyze Cam V2 (not a V3) and no, they are not the same firmware. https://support.wyze.com/hc/en-us/articles/360024852172-Release-Notes-Firmware :slightly_smiling_face:

The click sound if the IR filter moving in front of the lens.

After unpacking (un-zip) the demo_4.9.6.241.bin.zip you’ll have a file named demo_4.9.6.241.bin.
Rename this file to demo.bin and put it on a uSD card, 32GB (or smaller) format as FAT32.
With the uSD card in the Cam, Hold down the reset button and add power to the Cam.

If you’ve already done this and still have the yellow lamp then open a Support Ticket.
Live support is available: +1-206.339.9646
Monday - Friday 5 am - 6 pm PT | Saturday 8 am - 4 pm PT


Just updated 3 v2 cameras this morning. One of them bricked. What I do not get is Wyze’s response when io reached out. After trying to restart, reflash and reset the camera, they basically said SOL since you are out of warranty. Geez, your firmware bricked my device, which was working fine and your answer is to give me a coupon and by another camera so you can brick in the future?? Fool me once….