Wyze App Version 2.6 Releasing Tonight! (11/18/19)

V2.6.40 was the beta, but the public version has surpassed that and is V2.6.42, I also posted a screenshot of the public version in the Google Play store


Will this update now work with Alexa in the UK?

Hello @craigyboy007 and welcome to the community

Unfortunately it will not work with Alexa in the UK yet, I think there are many things WYZE has to do before they would be able to do that.

1 Like

Video is still horribly laggy (20s-30s) on my Zenpad 8. The most recent version that works properly for me is 2.4.82 with hardware acceleration :frowning:

1 Like

Hi, I wouldn’t have thought it be too much of an issue to make it work in the UK. Other Alexa apps work. I get the sign on but I think it’s down to Wyze not talking to the UK side of Alexa website… Shame as it would be handy to have :slight_smile:

With what FW?
On my Samsung J3 I found Android 2.6.42 to work well with V2 FW 4,9,5,28 but to be “horribly laggy” with the latest the official

1 Like

@craigyboy007, we would need to make multiple infrastructure changes (such as adding international servers) that we aren’t ready for yet to get UK Alexa approval.

@Poppycock, sorry to hear that this one isn’t working for you either! I’ll tell the team.


Hi Poppycock,

I have another version that optimized rendering issue. The download link is here. Please let me know if this version fixed your problem.


Yes, that’s fixed it. The delay is minimal now :slight_smile:


I am not sure what FW version added the shortcuts but when using an SD card the ability to quickly click on Playback is fantastic! So simple and easy thank you.


Wyze app 2.6.42
Android 6.0.1
Nexus 7 (2013) tablet
1 – Livestream video/audio is virtually lag-free (~1 sec) and roughly in-sync.

SD Playback video/audio is inconsistently out-of-sync: audio sometimes early, sometimes in-sync, and sometimes quite late.

2 – When viewing a 12-sec cloud clip Event, then tapping the SD card icon to go to the corresponding footage on the SD card, the Timeline has no < and > buttons to jump to the previous or next Event (as it does if SD Playback footage is accessed directly via the link on the Liveview screen.)

Is this by design?

3 – When accessing SD Playback footage directly via Liveview, fat-fingering the < button immediately after access (hoping to go to the most recent SD Event footage) changes the Timeline date to Dec 31 1969.

Tapping and dragging the Timeline back a bit first serves to avoid this.

4 – The status of the speaker icon (x’d out or not) in Playback doesn’t correspond consistently to the actual state of speaker off/on.

@HDRock @WyzeJasonJ Do you guys experience the same thing re erratic SD Playback audio sync on your Nexus 7’s?

1 Like

Same issue for me in this version (2.6.42). SD playback is now terribly erratic (jerky video and terribly out of sync audio). SD playback worked fine in previous version.

When jumping directly to SD playback (from the 12 second event video) using the SD card icon, there are no transport control button and, initially, no green bars indicating where video is recorded on the timeline. Once the timeline is “touched” the green bars appear, but there are still no transport control buttons. During SD playback the audio is lagging horribly

Constant camera connection issues since updating to the latest app (2.6.42) and camera firmware. This version is a complete mess on my phone. Android 6.0.1 on my phone as well.

1 Like

Meanwhile beta 2.7.14 is out,

Thanks, can you tell me where I can download 2.7.14 beta?


Second be ready for a bumpy ride. :slight_smile:


Got it… thank you!

Huh, Playback is smooth for me, just out of sync sound.

Haven’t had connection issues, either. Thank God for small favors. :pray:

I’ll be interested to see if 2.7.14 Beta improves anything for ya… :crossed_fingers:

Is it a net positive for you so far?

I completely uninstalled 2.6.42, rebooted my phone, and am currently running v2.7.377 test version. Connection issues are better (still have an occasional connection issue) and SD playback is better (except for audio sync) when it works (sometimes playback doesn’t work when using the SD “Playback” button from the 12-sec event video.) Also when I make changes in camera settings (notifications, detection settings, local recording, etc.), the changes don’t always appear to stick. For instance, I keep setting Local Storage to “Record events only”, but when I exit settings and check again later, the setting has changed back to “Continuous Recording”. Other settings are not sticking either. It’s doing this on multiple cameras (never had this problem before). Not sure which is worse – this or 2.6.42 which was unusable for me even after uninstalling, rebooting, and re-installing. Guess I’ll stick with this test version until something better comes along as I’m sick of messing with it now. Too bad I’ve wasted over half a day (literally) trying to recover from the “updates”. Thanks for help and tips guys!

1 Like


1 Like