When do tasks activate?

Hi RickO,

I’m a new customer, I have 3 cams (two wyze cam v2 , one in service porch facing backdoor, one in bedroom, and one wyze cam pan in the living room).

Using the task feature you discussed here earlier with another customer…I’ve created 4 task as follows.
Home - service porch cam & living room cam set to motion detection OFF w/days of the week set and time of day set…since someone will be home and don’t need detection and alerts.
Away - service porch cam & living room cam set to motion detection ON w/days of the week set and time of day set…since no one will be home
Dog monitor ON - bedroom cam set to motion detection ON w/days of week set and time of day set
Dog monitor OFF - bedroom cam set to motion detection OFF w/days of week set and time of day set

If I created schedule task(s) to turn On/Off motion detection with set days and times but when I created it,…the current time was 'with in’ the time window of the set times I want (example - Task # Away - set motion detection to ON at 8am Mon - Fri, Task # Home - set motion detection to OFF at 6pm Mon - Fri)…now when I created this task it was around 12 noon today (Monday)…so I then went to see if motion detection was turned on for each of my cams since I have that feature turned off on all 3 cams when I initially set them up…Here’s where I’m confused, when I went to check each cam settings to see if the set Task(s) had been enable, all 3 cams motion detection feature was toggle still in OFF position…(scratching my head). So I then restarted each cam to see if that would make the new Task(s) take hold - and it didn’t! I have to then manually enable motion detection for all 3 cam before exiting the app. So here my question - at what point does a new schedule task take hold (starts working) the day ‘of’ or the next ‘scheduled’ day…in my case…Tuesday?

I just want to make sure I set the scheduled Task(s) up properly and completely for what I’m trying to accomplish and make sure that the triggers and actions perform consistently on the days and times I’ve set up today so I can rely on the set up/system working. Maybe if I had created the task(s) at 7am to start at 8am Mon - Fri…they would have worked/enabled motion detection when 8am came earlier today, but because I created them at around 11:30am to start at 8am Mon - Fri, they won’t start the new set schedule till Tuesday? Please clarify so I can get this working right



I don’t really know, but I would guess changes due to tasks don’t occur until the clock rolls around the to set time. You might be able to figure out more if you check the task log which is found in My Account > Tasks > Logs in the production app.

1 Like

I have the same issue with setting the tasks for motion detection. Even when they appear to be set properly, the motion detection stays on when it should have turned off. I have checked and double-checked the settings. Any ideas?

This is what worked for me, and keep in mind I got it 2 work before they recently redesigned the entire UI which takes some time getting use too.
If you have scheduled task created (example - Away icon set to porch cam to record motion at 8am Mon-Fri ‘when you leave for work’ and Home icon set to porch cam to stop record motion at 6pm when you arrive home) - Now listen…if you have created this task say in the middle of that set time window - the task WILL NOT active until the next day at 8am, you’d have to manually set your cams to record events the same day you created that weekly scheduled task - UNLESS, you have created the task at 7am Mon to start at 8am Mon - Fri in which case, when 8am hits then Task will activate. Also, note that you can only assign ONE icon per task meaning you can’t set an icon to do both (turn on and off the same camera) so you’d have to create a task to activate record and another to deactivate recording events. Lastly, if you have called in sick, have vacation or are home for whatever reason and those task are performing properly and get you get annoyed by the frequent notifications of motion (because it’s you), just let them run their task…but turn off notification (temporarily for the app in settings on your phone) - DO NOT turn off the task in this case, because they DO NOT auto turn back on when you do have to leave the house on your regular schedule - a manual override on schedule task makes them either stay on or off way past the scheduled times they are to perform or not- I learned that the hard way. Remember it’s best to just create “dummy task” in 30min to 2hr intervals when are home all day so you can see if they succeed or fail in the short cut (task) logs, once you see they are succeeding their set actions you can then delete the “dummy task” and set your official ones for the house or office. Hope that helps.