V2 rtsp feedback - other cameras drop on the network

Thank you, Wyze team for rolling out the RTSP beta! I had posted earlier but wanted to respond here directly to WyzeArthur. My prior posts described loss of signal in Blue Iris. I fully understand that Blue Iris is not a Wyze product so if the issue were there, I would not look to Wyze for help. I did a test to see if the loss of signal in Blue Iris coincided with an inability to access the RTSP stream in VLC. It did. When Blue Iris showed no signal, VLC similarly could not access the stream. Once I regenerated the link in the Wyze app, the stream appeared in Blue Iris and I was also able to access it via VLC. I am certainly no network expert, but this leads me to believe that the problem is that the camera is somehow not sending the RTSP stream, which would be a Wyze issue, as opposed to a problem with third party apps not handling the stream appropriately.

Hi there. Thank you so much for testing this. Could you send me the device log, or the mac address of the camera to hzuo@wyze.com? Also, could you check if the Live View still works when that happens? Thank you so much.

Hi there. Thank you so much for sharing this. Could you take a device log when it happens next time? I will need your help to insert a SD Card to the camera, and after you hear “Ding Ding” sound, take out the SD Card and send the log file to hzuo@wyze.com.

Once again thank you for the help. I am aware this is a serious issue, but I cannot manage to reproduce it myself. Your device log would be really helpful for troubleshooting.

@ArthurH are you looking at all the feedback about RTSP testing? I posted this same feedback days ago here: RTSP in iSpy - #2 by MMediaman

Hi there. I saw that and I am testing it on iSpy with developer now.

3 Likes

How does one take a device log?

here you go sir. directions to send a dev log.

1 Like

There Dropping because the wyze cams can only operate stable on 2.4, Since your running AC/PRO I beleive you have 1 access point? For both bands, if this is the case I would monitor your router log with syslogd or rsyslog also on your desktop pc, do a arp -a from cmd. see if the wyze cams show up;also does your router show what bands the wyze cams are on? I am not an expert in any sense of the form, but i been known to dotslash a box in my day…just saying…

Oh yes, it is happening. For me, the camera lags, but it’s not even consitent. It starts real-time and then slows gradually until there’s like a second or two of delay. Then, the thing jumps to almost real-time. It’s very frustrating to say the least.

I wish they would give us an option of lowering the framerate or something so that we can decide for our selves if that would fix the problem. I’d much rather have 5-10 frame per second video that truly low latency and real-time rather than this.

I have over 3 different brands of cameras both wifi and ethernet. For wifi cameras I have a separate wifi network. All of my other cameras can stay real-time without any lag on my setup. The Wyze cannot.

I’m not even holding this to the standard of IP cameras that have been on the market for over 10 years. I wish they would announce whether they think this is a good experience or not and if they will be actually fixing it. They concentrate so much on warning us that it will not be maintained, when they haven’t actually released a usuable product yet. So many people are connecting to their cameras in blue iris, seeing that they connected, and proclaiming “yay! they work” without actually looking at the content.

I’m not sure criticism is reasonable for beta section of the forum.

Users have been practically begging for RTSP support and Wyze is making an effort to accommodate the need. As with any development, these things take time and ‘beta’ means not ready yet & help us make things better.

We’re all anxious for RTSP to operate in the most robust fashion, so let’s do what we can do to help. I have faith the issues will get worked out eventually.

You’re absolutely right for beta. However they officially marked it as released. That’s what triggered my comments here. : / This firmware should still be in beta.

1 Like

I just have to regenerate the link from the wyze when the camera drops

Ok agreed. Didn’t realize it was officially released. I speculate that maybe since the App has to incorporate RTSP functionality and other features are simultaneously being developed, it is too much risk to keep developing separate versions. @ArthurH @WyzeGwendolyn can either of you help us understand? Thx

We are working on an update for the RTSP firmware to improve it from its current state but I don’t really have much information. Here’s what I do know:

I’ll see if I can get @ArthurH in here. :slight_smile:

Thanks for the update @WyzeGwendolyn. The part about “A small percentage of users reported occasional connection drops and mild frame skipping” is quite interesting. I’d love to know what the other % of people are doing to avoid such issues since I appear to be in that small %. So far I am consistently seeing these type of issues in iSpyConnect, VLC and on mobile phone IPCamViewer.

Thanks

I’m sorry, I don’t have that information for you. I’ve personally never used RTSP so I’m not great at troubleshooting or suggestion modifications. :sweat_smile:

I have a Wyze Cam V2 and a Wyze Pan both running the RTSP firmware specific for each camera. The firmware installed and I confirmed the correct release in Device Info. Both cameras work correctly through the Wyze IOS App V2.3.25.

I have all Ubiquity equipment but I can not see the either Wyze cams through RTSP when I generate the URL. I have tried VLC, and BlueIris with the configurations noted here. Any ideas if my Unifi gateway, Unifi Switch, or Unifi WiFi is blocking RTSP?

Your situation seems unique since almost all other people who have posted here don’t have trouble seeing the stream (VLC, BI, etc)

You should probably systematically troubleshoot. Start by making sure you can contact the camera from where you are running the applications via ping. Then go from there… If I had to make a wild guess, I would say there is blocking/filtering going on somewhere in your route for port 554. Even your local Windows Firewall could be blocking…

I needed to turn off “block multicast and broadcast traffic for high denisty Wi-Fi networks” in the Ubiquiti gateway. After turning that feature off everything works. (or disable “block LAN to WLAN Multicast and Broadcast Data” in the settings->Site page or whitelist ‘excepted devices’ in the Wireless Networks settings on the Ubiquiti/Unifi gateway)

Hi all,

Yesterday i have also installed the beta firmware to give RTSP a try, and while everything works, in comparison it’s all a bit worse compared to using the Wyze APP.
Bit laggy, bit of frame drops, bit lower image quality. Now as WyzeArthur has pointed out, i understand that through the APP, the whole process from streaming, data transmission and playing the video is in hands of Wyze alone. Through RTSP there’s different elements at play.
But perhaps it would help if we can get some hints of how to set everything up as good as possible in favor of a smooth RTSP stream. I’m thinking of things like:

  • Ideal resolution/framerate to request
  • Perhaps disable features on the camera side that can be taken over by your NVR. So local recording, motion detection, watermarks, anything that will make the camera do additional work.
  • Ideal network settings to keep a smooth stream (TCP vs UDP, ports, static IP adresses, that kind of stuff)
  • Ideal video format or codec settings
  • Maybe even a feature that completely disables viewing video in the wyze app, So it only does RTSP streaming, and the Wyze app can only be used to do setup/configuration

Of course wyze knows all this stuff because you’ve made it work fabulous through your own APP, so perhaps you can show us how we can achieve the best possible result at home through RTSP.

PS. Of course the answer doesn’t have to come from Wyze if we can figure it out on our own. So please share your personal experiences.

2 Likes