Unable to upgrade to the RTSP firmware

hello i still cannot my firmware to change to the rtsp i tried 3 different sd cards and i am not sure what to do

This may seem like an odd question but what size cards are you using to try and flash it.

i tried 64 gb 8gb and 32 gb

I have only been able to flash cams using a 32gb card, the others would never work. I see that you have already tried a 32gb card though. I do not run RTSP so I am not sure of what other issues you could run into, hopefully one of the RTSP users will see this and give some more ideas.

what steps did you take to install it maybe i am doing somthing wrong and i dont realize it

The instructions I used are the ones in the link below for the V2 and Pan cameras.

Yes I tried that and still can’t get it to work.

Just for my two cents worth, I flashed RTSP to one of my V2’s several months ago with a SanDisk 32gb. Used the same procedure that @WyzeJasonJ gave you.
A couple of questions/ comments:

  • You don’t say if you are Windows or IOS on your PC. Note that the Windows file needs to be extracted before the Demo.bin can be copied.
    “1. Download a specific version of firmware, For Windows 10: Right-click on the folder and select extract all. For Mac: Just drag and drop the folder, put it on the root directory of your microSD card. For both Mac and Windows, rename the file to demo.bin .”
  • the part about holding the setup button while inserting the power cord can be confusing. You need to do this step exactly as described.
    “ 1. Hold the setup button, plug in your USB cable, and keep holding the setup button for 12-15 seconds, then release the button.”
    The long time holding the button is critical. And you need to be holding it down before inserting the cord.
    Hope this helps.

hello i am am on windows and i have done all of that and it still doesn’t work my light wont even turn blue it just goes to the set up where is says ready to connect

1 Like

Have you tried formatting your SD card in your computer before putting the RTSP Files on it? It could possibly be something with the card (s). There is an industry standard program recommended for use in formatting SD cards available Here. Be sure to use the full (deep) format option which will overwrite the card and either fix or let you know if there are bad spots on the card.
However, it really sounds like you are not holding the setup button fully down for the full length of time. It is just a little plastic’ lever’ that has to make contact with and depress the actual button inside the cam. It has a habit of being both too sensitive when you don’t want to hit it and also sometimes difficult to hit when you do want to.

You didn’t say if you are using a pan cam or not but it can be very difficult because of the rotation of the base.
This procedure should work if you follow it correctly. If it doesn’t, I would suggest you Contact Wyze Support. Be sure to detail what you have already done and post back to let us know what happens.


hi i am formatting my cards and i am using a normal v2 i have tried it still and it is not working and i im sure that i am holding down the lever

I had issues with the SD cards as well. Someone pointed me to this app:SD Memory Card Formatter | SD Association and it has helped a lot. Something to try…


I’m pretty sure the program @irishjd recommended is the same one I sent you. I second the recommendation that you not only use it but use the deep format option.
One last desperate thing to try. Download the latest firmware file from This Page and try installing it using the directions above for manually flashing firmware. If that doesn’t work you most likely have some type of defect in the cam.
I’m about out of suggestions. Unless someone else has ideas I again think it’s about time for Wyze Support. You don’t say how old your cam is but it may still be under warranty.


This is the correct answer and should definitely be added to the document. The disk should be formated as fat32 not exfat. The camera can write files to exfat, but can not load firmware from exfat. Saved my day. Thanks!!

I had the issue with a 128 sumsung micro sd card. The card was formatted as exfat when it came out from the factory. After formatting it as fat32 in mac, the status light can easily turns blue.

I am having the same issue on two PAN cameras. Tried everything, also opened a ticket with wyze support but still not able to solve this issue.
I am wandering if anyone has successfully address this issue?