Thermostat Help...Not sure its working like it should be

I tried researching and searching through previous post to try and find a solution but to no avail. I had a hard time setting up the unit initially but after working through I was able to get the unit to power up. The old unit in the house was hooked up like this:

Right now in Florida we are in the weird time when its colder than normal so we are using the heat for the 10 days a year we need it. My issue it that the heat isn’t kicking on like it should be. I can hear the fan blow but the heat isn’t coming out like it did on the old unit. In my previous unit the Blue wire was not hooked up but going through the set it, it would now power up the unit without it. It also told me to disconnect the Green wire from G. I’m not sure how far I am from being where I need to be but any help would be tremendously appreciate. Thank you for your time.


I went to the handler and tried to find a control board but could see one from researching others

I was able to wire the new unit to this:

you probably hooked up the C adapter (which you don’t need, you have an extra wire) incorrectly. show the C adapter wiring.

I dont have the c adapter hooked up, i could not find a control board in the handler per say. the wire and hooked up to other wires but not to a board like i have seen in other post. Its strange

by looking at the images i attached are you able to determine which may be incorrectly hooked up?

green should be connected, it’s for the fan. I would assume the blue C wire is connected at the other end since it powered up

I need to see the other ends of the wires to see what’s connected to where. And you should have G hooked up if you don’t have a C adapter and have a heat pump.

What wires did you tell the wyze you had?
I would have told it, from left to right
G, Rc, O, W, Y, and the blue wire would be C

Here are pictures from the inside of the handler. If remember correctly I did that combination.


I do remember it telling me to disconnect G when it ran a wire check. I just checked and blue is connect.

Connect the green wire to G and see if it works.
Sometimes the wire checker is wrong. I see the green wire going into another wire nut with a wire, so it should be connected.

What kind of secondary heat do you have? gas or electric heat strips?

So I connected green to G and it kicked on heat like it should. I have electric. Right now its 70 outside so heat wont kick on till tonight when it drops. In a weird time where its kinda stagnant, not hot enough for air and not cold enough for heat. Trust me not a bad thing but I just wanted to make sure its functioning properly. Thank you guys so much for your time and input, truly grateful :pray:

1 Like




So now that it’s “warmed” up in Fl I went to turn on the AC. I am not getting any air coming out of vents. I can hear the fan outside running but nothing is blowing. I connected the Green to G.

Being that the old tstat didn’t have blue hooked up does that have anything to do with it since it’s now hooked up ?

I also live here in Cold Florida too. This is a rare bird for a hook up and the Main HVAC unit. Everyone I have seen use screw terminals. I have a Electric Air and Gas Heat. Their was no Common wire (BLUE) used. After numerous tries I figured out that I had to use the C(adapter). At the HVAC unit I hooked up all the wires on the C(adapter) RC G Y W and add also add the C(common) wire. Back at Thermostat plate I put a the wires back except i but the Green wire in the C plate I never used the blue wire.

If you try to run the indoor fan manually does it run? Iirc the wyze has some advanced settings that delay the internal blower fan when the air conditioning is called.

If you have an extra wire, it is better to use that than to use the C adapter. Really the C adapter is only good if you don’t have enough wires in your run,

So if I turn the fan on in the app it kicks on but still nothing coming out of the vents.

If the blower fan is running, then air must be coming out of the vents unless there’s a hole somewhere. You’ve got a heat pump, so it’s possible that you have it switched in reverse, maybe it was cooling when you were running the heat strips, and now it’s heating? if so, go to advanced settings > swap hot and cold.

So last ditch effort. I re-checked my connections. I then deleted the device and started from scratch. I reckon during the set up process I select another option during the “heat” part. I selected other and it finished the set up. I noticed this was different when i went to run a system test. It looked different. Instead of asking if the furnace felt hot it was asking if I felt hot/cold air from the vents. It is now blowing cold air out of the vents. Ultimately it appears as if I messed up during the setup proces. Thank you Speadie for your patience and assistance.

1 Like