Thermostat - furnace doesn’t “pre heat” anymore

I am assuming you have a gas or feul oil furnace. Turn off the power to your furnace, disconnect the G wire (fan)at the Wyze thermostat. Turn power to furnace back on. The fan limit control on your furnace should now control the blower instead of the t-stat.

I as well appear to have this problem. My “G” wire is connect at the thermostat just as Wyze said do in the limited directions. My fan comes on when heat comes on. Should have a ramp up time don’t you think?, My removed thermostat did have a ramp up time.
Does removing the “G” wire at the thermostat correct that problem?

If I remove the G wire so the gas furnace heats up before the fan comes on, won’t the AC not work come spring?

You are correct, but I’m hoping that Wyze will fix the firmware and release it before then. If they don’t we have two choices -

  1. Put the G wire back on and hope that the Heating season is done,
  2. Leave the G wire off and add a jumper at the furnace control board between the Y and G points. That will make the thermostat Cool command activate both the A/C and the fan.

[Edited to add italicized words in option 2]

Confirming my two choices:
I can do 1 or I can do 1+2. Correct. When doing 1+2 then the jumper will solve the problem of the fan coming on prior to the furnace preheating. The jumper forces the furnace to preheat before turning on the fan. Correct? And Leave the G wire connected?

No, the choice is put the G wire back on (good for A/C, bad for Heat) or leave the G wire off and add a jumper in the furnace. If you were to add the jumper with the G wire connected it would run the A/C whenever fan was called for, including during Heat cycles. That would be a problem. (I’ll edit that post to make the choice clear).

The jumper forces the fan to run when the thermostat is calling for A/C (with the Y wire). It does not force the furnace to preheat, the furnace chooses to do that on its own with or without the jumper.

But let’s hope Wyze issues a better firmware before we need A/C.

[Edited to clarify choices and effects]

There is a reply near the bottom of this one from Wyze. Sounds like they are working on it.

Yes, I had read that comment from @Chuan . I hope they make the change even better than he wrote; I don’t think 30 seconds is good enough for a delay. I would like to see it be a selectable option. In my furnace I would not select it, but there may be some people that need it. (I think that’s why Wyze did it like they did).

I like the way you’re thinking and concur that would be a better option than just a straight 30 seconds. :+1:t2:

This is a great thread. Unfortunately, I do not have a green wire on my wyze thermostat to disconnect. Only C, White, Yellow, and R. Apparently what was the green wire is now the C. I can tell that the furnace is trying to engage the fan after the thermostat has already turned it on because about 2 minutes in, the fan goes off and on. We really just don’t want cold air for the first 90 seconds.

Edit: Added italics phrase.

I’m having the same problem as everyone else here.
My newish Honeywell had wires on R, C, G, W, Y
with a small jumper on a separate RC/R connection.
After installing the Wyze Thermostat on a Forced Air Gas Furnace, this is what happens.

  1. Inducer motor AND Fan Motor turns on.
  2. Hot Surface Igniter gets Hot.
  3. Gas starts and ignites.

How it’s supposed to work:
As long as ALL SAFETY Checks are completed between each of the 4 stages.

  1. Inducer motor comes on.
  2. Hot surface igniter get hot.
  3. Gas comes on and lights.
  4. Blower Motor starts blowing pre-heated air.

So… What’s the dill pickle?

1 Like

New firmware update today!
Hopefully this works.
Going to update and test now


Wyze Thermostat Firmware

1.1.2 (March 10, 2021)

  • Changed to a new filter reset mechanism to fix an Android issue preventing filter resets
  • Improved calculations for users traveling across time zones
  • Added a 15 second delay between fan and heating to prevent cold air from blowing before the furnace warms
  • Added a differential temperature feature to give more control of temperature accuracy to balance savings and comfort
  • Bug fixes

Unfortunately, adding a 15-second delay between fan and heating did not fix the problem for me. With the update, my fan comes on for only a brief second and is immediately shut off by the furnace. Apparently, the arbitrary choice of 15 seconds is not quite long enough for my furnace. Now, I’ve got this extremely short cycling of my fan motor, which I know is not good for it despite what Wyze claims.

Why is it an arbitrary 15 seconds? Is that long enough for others on this forum?

The problem, as pointed out by many folks elsewhere on this forum, is that the thermostat simply should not turn on the fan when calling for heat from a gas furnace. The furnace itself will control the fan, independent of the thermostat, and turn it on only when it is ready. That’s the way thermostats and gas furnaces have interacted for many, many decades.

Why not fix this correctly and not turn on the fan when calling for heat from a gas furnace?

The 15 second delay did nothing for us. Please allow us to set the time delay or turn it off completely.

1 Like

The fan motor is one thing, but the heat exchanger may rust when cold air is pumped through too early, and the aborted run is also causing double duty for the capacitor. Wyze is looking into building in an option to disregard the G-wire for heating altogether, but that will be a future update.

For the above reasons I have disconnected my G-wire on the Thermostat. This allows the furnace to do everything it needs to do on its own. It takes my furnace at least 80 to 90 seconds to start the fan, so the 15 seconds delay is nowhere near enough.

There is a “Gas - Other” setting that may do the same thing, but that should be set at install time. I have not found a way to set it after the fact.

(If you disconnect the G-wire, be aware that it is necessary for cooling, so you’ll have to reattach it when it gets warm and need A/C.)

You will need to delete the thermostat from the app and reset it on the wall. Before you delete it, take two screen captures showing the temperature preferences and the details of the schedule (the Edit Schedule screen). Reconnect the G wire at the thermostat and then go through the setup again. Select Gas and then Other.

When you run the tests you will feel the blower come on when the furnace selects it (not the thermostat), and in AC mode it comes on right away, Someday Wyze will get this right.

Yeah I’m not gonna do all that :smiley: Here in the desert we have a ‘nice’ season and a ‘too dam cold’ season. There’s not much in between aside from a couple of weeks that neither heating nor cooling are required. It’s disconnected now but because it’s too dam cold, but I can last until Wyze has added a ‘disregard the G-wire for heating’ option to their App. By that time we’ll be in the nice season and the G-wire will be reconnected, after which it will not have to be disconnected ever again :crossed_fingers:

So is still going on with the recent firmware updates or has it been fixed? I was thinking about switching from my perfectly good Nest over to one of these. I know, some may ask why I would do that. But I don’t want to until they can get the basic functions working for a gas furnace. Thanks,

Still not working correctly. They put in a 15 second delay to start the fan…so after 15 seconds, the tstat starts the fan, then the furnace control board shuts it off a few seconds later, and then starts the fan at the appropriate time, once it’s up to temp.

15 seconds isn’t enough time. 90 seconds maybe. Or what it should really do is leave the fan control up to the furnace in this case.

Thanks for the update. I ended up double posting in another thread, so I will stop doing that. I will hold off switching my tstat until they resolve this.