Scheduling plugs

As long as I have it set on AM it works, but if I add a PM setup time it fails. This AM time setup below keeps all the days selected after I exit the rules.


You should be able to fix this for now by making two rules. One to turn it on, one to turn it off. From a code logic standpoint, this is easier to follow anyway. Using a duration for on/off functionality suggests that it will “Turn On” continuously for the entire period of time, which doesn’t make a lot of sense. I don’t think that’s what happens in practice, per se, but the way they implemented this logic bothers my code brain. Haha.

No. Read the OP. I’ve tried making two rules and it simply does not work.

Add to that, if any off time is set to PM it fails, as I note it the other post similar to this. If the time is set to 1159pm the rule immediately fails, but edit that rule to 1201am and it works.

1 Like

Yes, same here, on at least one plug. In my case I wanted a power at a plug to be available all day, bit not at night. (Small heater I wanted to make sure was off at night.). With a few tests, it seems to have worked and save correctly, if the on duration was 12 hrs or less … Otherwise same strange behavior ad OP. I got around the issue, (so far), by scheduling an off time for night (11:00pm to 5:15 am,). So far, so good. I suggested to support, that perhaps the 12 he am/pm clock logic is off, and maybe there should be a 24 hr/military time clock option in the app. She suggested I add as a suggestion in the forum.

1 Like

Wyze doesn’t seem to understand military time, which my phone is on always. Instead of adapting to the phone setting, the app “resets” my 2300hrs to 11:00pm.

My schedules were less than 12 hours… only 4 hour in fact (1830 to 2230), so it isn’t associated with a 12hr or less schedule, but when the end time is programmed for - any PM time.

Hmmm… Come to think of it… It may have worked up until 12:01pm…so that would match yours. Code wise, a 24 hr clock SHOULD be much simpler to program. When I suggested a 24 hr clock option, they said they always suggest that. Then I went back to the program, and didn’t find such an option, and didn’t want to mess with my phone config, as I had come up with a work around. When I replied back, they suggested adding the 24 hr clock option as a suggestion in the forum. So, guess THAT fix … Isn’t. :frowning:

The 12/24 hr option is already on the wishlist.

I found out that the days will save ONLY if you create a rule that’s pm to pm. I made a 11:20 pm to 11:21 pm schedule for a plug that saved properly and worked. I think it should work with any pm to pm time though.
Similar to what @StopICU33 was saying that his AM to AM rule worked.

@None you tried scheduling a 6:30 pm to 1030 pm and it didn’t work? I also got that weird unknown device error too when I went back to the rule and tried to modify it. I think you would need to create a brand new rule instead of modifying an old one. Also, I noticed it wouldn’t let me create any rule for scheduling devices on too for a temporary period of time. It said none of my devices were supported

I agree that this problem needs to be fixed!


Been there. Done that. Tried everything. No dice.

1 Like

FWIW - Wyze replied to my support ticket - told me to try logging out of the app, and back in. Over mobile data, that seems to have allowed me to edit existing plug rules so that I can have a 6:30pm to 10pm schedule. Also, allowed me to make new schedules without any issues.

Just need to verify that it works on the home wifi.

Shocking that this is all it took.



That worked for me too. Thanks for updating us. That was a surprisingly simple fix.

I just a bunch of these plugs.

Playing with the Schedules, and i n my test of a plug turning on then off after 1 min, to make sure I understood the settings right…it worked fine.

But i want my night light in kitchen to turn on at 4PM and off at 8AM the next day.
I can not get this to work.
I have tried one schedule, with start and end time, with action Plug Turns on.
I have tried separate schedules one for on, one for off.
Plug is not doing anything.

App is the current app from Play store.

How are these plugs controlled? are they set in plug memory or on WYZE server?
Meaning is it independent of the phone with the WYZE app being on or not?

You would use a schedule rule for this. I wrote one that will do what you want there is a screenshot below. This should help.

Perhaps u did not understand…

I have things setup that way…

It does not work…for such long periods of time.

It will work for very shorts of time, like within 1 hour on same AM or PM time of day.

There is several other threads i found that are full of users complaining that this is not working.

I understood you, was hoping this would help you. So you are saying the plug does not stay on for the whole time?

Is the plug in an outlet that is connected to a switch that might have been turned off by accident?

It does not come on at set time, does not go off at set time.
Does nothing.
I have to manually turn it on off. (via the app or GA)

I would open a support ticket with Wyze Tech support. You can do that here. We are just users like you but Support actually works for Wyze.

As an other thread suggested. Loggin out then back into the app and adding the Schedule seemes to have worked. at least the plug did shut off this morning, and did come back on later. so far, so good. hope it stays working.


The one plug i have set scheduled, been working fine each day.

FWIW, I think Europe and maybe most outside North America use 24 hr time. We lived in Norway for a while and it does make sense, my wife still uses it. In general, apps should use the phone settings.

Anyway, I got 2 scheduled. One AM for coffee pot is On for 10 min and it is working ok, well avg run time is 12 min which is acceptable but a 20% variance is not really very good. Pot only takes 8 min and has a low level shutoff for the heating element so it’s not hurting anything. Second is a PM, lamp on On for 5hr 45 min, so it’s off before midnight. This one has had a couple of noticeable glitches - coming on 10 min or so late a couple of times, avg run time is 5 hr 13 min - close to 10% off. So far I’ve only had to manually turn it on once and off once. Again it’s not a critical issue but just strange why a time function is not exact. Even my old digital and mechanical timers were exact and the digital even compensated for DST. Basically these give us the convenience of app access to manually operate or reprogram but the flaky behavior leaves them less useful due to suspect reliability.