Plugs not working on rules/scheduls

I have the older generation plugs in my house. Seven of them. They were working just great until late December and now they don’t want to seem to keep a schedule. They are going on and off at all kinds of bizarre times but if you look at the log the logs are correct. I tried calling Wyze customer service and got some lady in the Philippines who is very nice but not very knowledgeable. I am getting ready to jump ship. I have three cameras that work fine, I am wondering if this is related to the AWS issues in late December? Any and all help would be greatly appreciated. I have deleted the rules, deleted the plugs and redone them. I am really not happy to wake up at 4 o’clock in the morning to find lights on in my house even though they were none on when I went to bed.I would love for somebody it was to reach out to me.

Some things to try…remove the plugs from the power outlet, wait about 30 seconds and plug them back in. When you say the logs look correct, can you be a little more specific about what you see there? I assume you can turn them on and off in the app manually? What firmware version on the plugs? What app version/platform: apple or android?

Thank you for responding. I am working through iOS. I have deleted the devices. I have deleted the schedules. I have unplugged the devices after deleting them. All my firmware is up-to-date. If I look at my logs it will tell me that the light is on but when I look at the light that is connected to that particular log it is in fact not switched on. I can manually switch it on from the app. The whole set up seems a bit wonky when I set a start time and then end an off time and then I have to go into actions and tell it to start/stop.

Two more options that probably won’t make sense but have helped others with stranger problems.

First , try clearing the cache for the app. You do that under the accounts tab and app listing. Second, try rebooting the phone.

1 Like

OK so here’s what I’ve done, I cleared the cache. I deleted the rules. I deleted the devices. I have reinstalled the devices and reinstall the rules. All my firmware is up-to-date on my router on my Wyze app and plugs. We shall see.

This is an example of one of the rules for my seven plugs

In your example, your plug will turn on at 15 minutes after sunset and immediately turn back off. Specifying and End Time automatically performs the inverse of the Action “Turn on” at the specified end time. Simply delete the “Turns off” action under “Add Action” and tap “Save”.


1 Like

I am confused. Do I have to have a separate rule to turn on and turn off my plug. Then why does it ask me for an end time. I had these things running seamlessly for a year and a half. I appreciate your time, If you could give me a step-by-step on how to set up the turn on time at Sunset, and then how to get it to turn off at 10:20 PM I would be grateful. Thank you


End time is not required, it is optional.

Your schedule will turn your plug on at 15 minutes after sunset and off at 10:20pm if you just delete (click the red circle) the Turns off action under “Add Action” and click “Save”.

Wyze not only changed the app interface, they changed the backend rules engine in the cloud. They slowly migrated accounts over to the new rules engine over the course of last year and that endeavor has been completed. The migration did come with some odd problems and new learning for most of us with existing rules/schedules. Once my account was migrated, I ended up deleting all of my schedules and started over to save the headache. I’m sorry you’re having to go through this pain. :face_with_diagonal_mouth: When you get used to the new logic behind the interface, you’ll find that the rules/schedules/triggers are much more capable, flexible and require fewer rules to accomplish the same task.

1 Like

Thank you

1 Like

This worked for me

I had factory reset the outdoor plugs a couple of times and deleted the app. But clearing the cache fixed the problem

Strange that even after deleting the app and reinstalling , the cache showed data

Mar '24. Plugs stopped turning off according to Rules right after switch to DST. I tried a few simple things short of removing/adding the plugs. Then I saw this post. I cleared the cache in the app and plugs now follow the rules. Very weird, however, when something that was working suddenly stops working.