Failed to update device list (error code 3044)

Same error here. Like others, I can get the error when connected to my local WIFI network. Problem goes away when I disconnect from WIFI and use LTE or another network

Sorry for the inconvenience. Could you submit an App log? Thanks!

I don’t think device type is the problem. When I disconnect the wifi or wifi with VPN, there is no problem. I have Home Assistant Wyze (Unofficial) plug in install on my home network. If you ask me, I suspect there is a new rate limiter implemented from Wyze’s side and limit number of calls from any source.

3 Likes

I would but the app gives me the error “Upload failure” when I try. I’ve tried a few times now both on my WIFI network and off it. It doesn’t work.

Hi @WyzeBaohua, my log id is 275677. Thanks.

Ah yeah, you’re right. Just saw this in my home assistant logs

home-assistant | wyzeapy.exceptions.UnknownApiError: {'ts': 1629171277321, 'code': '3044', 'msg': 'RequestsTooFrequent', 'data': {}}

2 Likes

And just noticed this on the ha-wyzeapi github page

NOTICE: Wyze has started rate limiting the requests to the service that this integration relys on. Until a solution to overcome this is found it is likely that this integration will cease to function.

Yeah, I see that in my logs as well. It’s making sense now.

Edit: I turned of my HA docker about 12 hours ago. I’m still not able to access any of my devices or add the new devices I recently purchased.

My devices are essentially useless at the moment.

Hi! For everyone who got Error 3044, this issue will be resolved by tomorrow. Please use LTE as temporary way to view devices. Sorry for the inconvenience!

4 Likes

I just realized I am affected by this. I need to find a way to free my wyze bulbs and plugs from the wyze cloud service.

2 Likes

I did find it rather suspicious that seemingly all the people with this problem used home assistant. I hope they turn off the rate limitation as bzhu implies. Or better yet, make an official HA plugin.

1 Like

so… it’s tomorrow.
I’m still unable to access the devices on my LAN via the Wyze app or HA integration.
Are the API rate limitations being rolled back to the previous commit? Or is there internal discussion on whether or not to allow the access going forward?

4 Likes

+++

I am also looking forward to resolving this error.
@WyzeBaohua It was very convenient to turn on my Wyze Cams with the help of Home Assistant

1 Like

The way forward for me is to replace them with different bulbs, plugs, sensors, etc. I was already doing this little by little. Stuff like this just hastens the process. I hate the current situation with the v3 cams. They’re almost awesome but they may need to go too. I’m wasting too much time on this.

1 Like

Yes, it appears that HA was/is the issue. I deactivated my HA and am hopefully they will fix this issue. If not ill be replacing everything this weekend and only utilizing old wyze cameras with RTSP.

Fingers crossed they just let us build a real integration and be done with this.

2 Likes

I did the same but 12 hours later the app is still giving me the same error. Hoping it’s resolved in the next 12 hours as I can’t move my pan/tilt cams right now making them just about useless.

1 Like

Ive been talking with support on this issue since yesterday and was advised with the following information; “This is an issue we are aware of and that our team is currently working on. In the meantime, we request that you use your phone’s data in order to access your device list, and ask that you please stay patient and be on the lookout for an app update that resolves this issue.”

1 Like

Same issue here.

To me, this is just another nail in the coffin for wyze products for me.

Their app sucks for auto unlocking their lock reliably. Try Home Assistant with a reverse engineered API, since they fail to provide an API. This made the lock somewhat usable, again… Since they’re app is garbage for auto unlocking… They then rate limit the workaround.

I already had to use wyzehacks and setup an nfs server just to be able to record with their campan dive their garbage firmware makes it corrupt the sd card about once a day.

The products are “meh” to begin with, the only thing they gave going for them is the price. Pretty much everything else makes the hassle of dealing with them not worth the savings from the price compared to other products.

Other products may be twice as expensive, but they’re at least twice as little of a headache as well … And likely work far more reliably.

1 Like

Yep I can get access to the app again but it’s marking most of my cameras offline. Both Pan/Tilt are offline after multiple restarts and clearing of sdcard. They are blinking blue as well but are pingable etc. I am running the RTSP firmware so I don’t suspect support will help me at this point and getting to the cameras physically is a lot of work due to their install location. Time to move on from Wyze for me at this point. Great price point for what they are but if you want any ability to record beyond their app/cloud/sdcard you are screwed. RTSP is still working and the cameras video streams are still working making me think this is a backend issue rather than an issue on my end.

1 Like

Created a forum account just to reply to this thread to voice my frustration at Wyze for making whatever changes they made yesterday.

Same as others in this thread;

  • Use Home Assistant to control Wyze Bulbs, Plugs, Cameras around my house and rental
  • Everything stopped working from within HA
  • Error 3044 in the Wyze App
  • Disabled ha-wyzeapi in HA
  • Error 3044 still displayed in Wyze App, devices not usable while phone is connected to wifi

I’ve probably spent close to $1500 with Wyze, a huge fan of their products and technology…hell, I even bought their early access for the new vacuum (all of them) not because I needed them but because I wanted to support the company. Changes like this make it very hard for me to want to continue to support Wyze. I looked past the issues of Wyze not allowing direct API access locally to their devices, and was grateful to at least have cloud based API access…but, now that appears to be gone.

Wyze…please help your most loyal fans. If you’re trying to harden your cloud API, I get it… at least give us power users an option to integrate into systems like Home Assistant. Hell, I’d be willing to pay a monthly fee to allow it (perhaps it should be included in CamPlus?).

I’m tagging you, @WyzeJimmy, I feel like we’ve been through a lot together.
Me, sending Wyze large amounts of my hard earned money, and you, sending me weekly updates of where our preorder items are in the supply chain process. Really hope you know someone in engineering that could help us, perhaps @Elana could get someone to push out local API capabilities?! :slight_smile:

/rant

6 Likes