Can't get v2 Cam to keep connection to network

So far I have had nothing but problems with this camera. From the very beginning it has been such a PITA I am about to throw it against the wall. So anyways, here are my issues…

I was able to get it to setup without issue, at first. Then after about 2 minutes of it connected, it loses network connectivity. Great! So I try to recycle the power, and it will not reconnect. So I tried to run setup again, and I can get to the portion where it scans the QR, and it WILL NOT scan… All the camera does is make clicking sounds and the lights flash.

Obviously this isn’t normal. This happens regardless if an SD card is in or not. When it was connected it tried to updated the firmware, and failed. Not sure if that has anything to do with it or not.

Do I have a defective camera?


It sounds like you may have a defective camera. I would look through the troubleshooting guides first, and then if you can’t resolve it, then submit a support ticket.

Here are the troubleshooting guides:

If that doesn’t solve it, keep in mind that this is primarily a user-to-user forum. If you don’t get help here from the community, file a support request including log files. That will ensure that the logs are captured. You might want to submit the ticket right away because there’s somewhat of a backlog. You can always let them know it’s already resolved when they contact you.