Cannot login on website: TOTP Verification says Internal Error

Hi,
while tryin gto login services.wyzecam.com , the TOTP Verification always gives me an Internal Error. I even try my recovery code, and it’s the same error message everytime. What makes the whole process even more confusing is that on the login page, where it says “please choose the authenticator app”, it only offers WYZE as an option and I don’t see GOOGLE AUTHENTICATOR APP as an option even though this is what I setup in the app as Multi-Factor authentication.

Ultimately, I’m trying to activate a 3 month free Cam Plus promo code, but I can’t do it within the app and on the website I can’t login. This login process confuses me deeply.

What makes it even weirder is that I had no trouble loging in the forum…

Any idea or suggestion?
Thank you.

Martin

Welcome to the Wyze community @martinperreaultphoto!

This link displays an invalid error.
Have you tried https://services.wyze.com/ (Wyze.com instead of Wyzecam.com)?

Going here will bring you to the login, it’s the same as the Wyze app. You can then enter your redemption code by choosing the “have a code”?” button.
https://services.wyze.com/user/login

Try it out and let me know how it works.

The login link you provided me with forwards me to this link: Wyze Home Monitoring Service
I am presented with an option: “Multi-Factor Authentication”
and it says: “please choose the authenticator app” and the only option is “Wyze”. I click NEXT.
Next page says: “TOTP Verification” and requires a “Verification Code” or a “Recovery Code”.
At this point, anything I try brings me to an error.
I tried entering:

  • the promotional code I have in my email
  • the number code from Google Authenticator App
  • the recovery code I was given when activating Google Authenticator App with Wyze

I also tried clicking on HAVE A CODE link at the top right, but that brings me to the beginning of the login procedure where the process above starts all over again.
I`m caught in an endless loop…

It`s like the two step authentification does not work,…

I’m not too sure why this is happening.
You may want to contact Wyze Customer Support about this issue!
By phone: (206) 339-9646 Available Monday - Friday 5 am - 6 pm PT and Saturday 8 am - 4 pm PT
Or online: Wyze.com/support (click “submit a request”)
phone support is typically faster however this isn’t always true due to fluctuation in the amount of calls.

After talking with support, we found the following two solutions that I’m posting here in case someone else encounters this problem:

SOLUTION 1: USE INCOGNITO MODE
using Incognito Mode in Google Chrome worked. Two Factor Authentication went through instead of yielding an error.

SOLUTION 2: CLEAR WYZE COOKIES
In Google Chrome, clearing all Wyze Cookies reset the login procedure and solved the issue. This solution does not require Incognito Mode and login now works normally.

Cheers!

2 Likes