Battery life inconsistency

I have 4 outdoor wireless cameras. These are new cameras activated on November 6th. 3 of them are functioning fine. The one that is giving inconsistent readings on battery charge. Starts out at 100% drops to 93% then to zero. Charged it up and it read 0% for an hour then jumped to 100%. Put it outside and the readings bounce around from 100% to 32% to 20% to 30% and now 24% within 2 hours. How do I correct this issue?

Welcome to the Wyze community @Bodon!

This is an interesting issue.
Make sure your camera and base firmware is up to date.

If your firmware is updated and your still having issues, try deleting the camera and adding it back.

The firmware is up to date, I have deleted the camera and re-added it. Still won’t hold a charge or sometimes even charge. Right now after charging for 1 hour it reads 0%. It initially read 3% and now the right light on the back is not lite. I really believe it is a defective camera/battery.

how are you charging the camera?

I have seen a few people charging them in ways that aren’t indented and I could see that having some effect possibly.

Using the power adapter and micro USB cable included with the camera.

1 Like

try plugging it into the base to charge a few times and see if that gives it more consistency

you mentioned that it is getting to 0% does it actually stop working as if the battery dies?

I wonder if it isnt the indicator is not calibrated wrong and what appears to be a low battery actually isnt.

let it run and when/ if it gets to 0% see how long it keeps going. if it does right away I would indeed contact support and have it replaced under warranty. if it doesn’t die and continues to run at 0% it sounds like a bad calibration and will often recalibrate over the span of a few charges. ( the need re calibration is something we saw with the Wyze band when it was first released)

1 Like

I have tried charging it via base station. It read 0% and does not connect. If I turn the camera off to charge or if I leave it on, I get the same results. Doesn’t matter if I am using the base station or the adapter that came with the camera to charge it. This is a new camera as of November 6th. It worked fine for 6 days then all of a sudden stopped working. It is not in direct sunlight. It is on a covered front porch at least 10 feet away from direct weather. The other 3 camera on the network are still working fine. Those camera came separate from the bad one that came with the base station.


yup, it sounds like you might need to get a replacement. I would contact support. they will probably have you run through some things just to make sure ( its kind of silly but keep in mind they don’t know the full situation)

When it gets to 0% it no longer connects. I tried to refresh, but that doesn’t change anything. I did try plugging it into the base station, but that didn’t change anything either.