Wyze cam V3 stuck on solid red light

Happened to me too. A v2 is fine but a v2 no micro SD card but did have a power failure.

I have had this happen to one camera three times. Allow me to explain. I have 5 cameras around my property. One of them developed this “frozen/red light on” issue. I called Wyze and after much troubleshooting, they replaced it. The second camera soon developed same issue. This time I had it replaced through Amazon. The third camera developed the issue almost immediately after installation. All three have been powered using the same 20ft usb cable. I have others on the same length of power cables so I do not suspect that. I also used the same 128GB card in each of the three. I use the same size and brand in my other cameras without issue so I don’t necessarily suspect the card either. I did reuse the power adapter from the first camera so there is a possibility that it does not produce clean, consistent power I guess but I am not sure why that would brick a camera. All of my camera, including these three, are at the latest firmware version. Again, no issue with any but these three. I have yet another replacement coming but I am afraid to install it given the track record thus far.

1 Like

So I tried the latest update on one of my V3s and the same thing is happening. Wow. Anyone was able to update successfully? Have to be something causing this error.

1 Like

Wow. I am terrified at the idea of updating the last two cams that I still have!!! :man_facepalming: I was hoping that the newest firmware would take care of bricked cam v3 issue but it certainly seems like it is not the case. :unamused:

I am thinking it has to be a common issue causing this. Something we are overlooking. Wifi is good don’t have connection issues.

Putting some thoughts behind this… :thinking:
1- when the cam is bricked it still can “READ” SD content (otherwise the LED would not turn purple)
2- bricking is apparently not generalized on v3s as some people are not affected by this issue
3- bricked cams can’t complete the boot steps even with no SD cards in the device

I am guessing part of the initializing process (booting) is based partly on ReadOnly ROM (logical practice to be able to recover from an update that went wrong for instance) which then reads the content of a Writable ROM which appears to be updatable (since an OTA update doesn’t require an SD card to update the cams firmware right?).

Conclusion part of the writable ROM somehow gets corrupted while updating the cam firmware OR during regular usage (based on my observations).

You would think that a manual firmware flash would fix this but it doesn’t, which tells me that the flashing code “WRITING” is also updated by the firmware (meaning when the writing code gets corrupted it can’t bring the cam back even when doing a manual flash) and appears to be accidentally updated/corrupted during regular usage (I would guess the firmware ROM writing code shares a cache with the filming code and so one will accidentally write where it should not when a specific set of variables match triggering the writing bug ).

My theory?
It would be technically possible to fix the cams by writing (with the proper tools) directly in the writable ROMs (bypassing the cams own writing code) a clean writing code. But since there appears to a bricking bug in the cams there’s a chance that the problem would happen again.

Question do we know of any Firmware version where no nonsense bricking occurres? That firmware may be the only way to prevent this issue from happening until wyze has done its homework of fixing what appears to be a firmware bug. Otherwise cam v3 are living on borrowed time and luck.

1 Like
Other option would be writing directly to the chip.That requires thinkering with hardware and tools.  But, all those solutions should not be needed. Wyze been mute on this, just replacing cameras, not a great business model, but oh well.

There’s a new update out, afraid to do it, but on other hand, if it breaks another one, now it’s the time.

1 Like

You have coverage from Amazon? Otherwise the only way to have the cam exchange under warranty is by having the RMA cams shipped in the USA but then the border is closed because of covid so you can’t retrieve your replacement cams.

First 30 days you can return it. After that SOL.

Ok I understand… Yeah now is perhaps the time to take a chance and have the cam brick on you I guess… I checked and the 30 days ended july 28th.

I guess I won’t touch the firmware update just in case that it kills my last cams.

1 Like

Well, did the update this morning. It did 2 updates. .18 first to prepare for .19. release notes don’t really shed any light of they solved this issue or not. Seems to me something has changed way they update the camera.
So far, it works.

1 Like

Have 4 v3’s that are on 4.36.1.14 firmware. Can not auto or manual update to newer firmware. All result in red light and will power cycle every 3 minutes. Was hoping the new 4.36.3.19 firmware would work, but it did not, had to manually revert back to 4.36.1.14.

Weree you manually installing to the 19 firmware? Also what app version are you on

I just attemptted the manual firmware update. As directed I placed the firmware on a SD Card and held down the setup button, plugged it in. I continued holding until the light became purple. Release. The light stayed purple for awhile then went back solid red. Now it’s still on solid red. Any other suggestions?

App version is 2.22.21 android

I’m trying to go back to a previous firmware but still nothing. I guess these set got bricked as well.

1 Like

Was the camera working before manual update?

I haven’t been able to get revive any of mine when led turns red , and stays red.
I also tried older versions, nothing.

I tried the latest update and the camera went on solid red right after. I was advised to try the manual firmware update to see if it will help.

This is the thing I cannot get support to understand. Once the red light goes solid, the camera is dead. No combination of power cycling and reset button holding will make any difference. The unit will not load ANY firmware update, old or new. The light will never change from red to purple to show that it is even trying. Once it get the “red light of death”, there’s no bringing it back.

2 Likes

What size SD card are you using? Needs to be 32Gb or less, Fat 32 format.
With that combination, light will turn purple, only to turn red again and stay bricked.

1 Like

I believe only way out, get a replacement from Wyze.

1 Like