wyzecam registration fails most of the times and if it registers streaming fails

I had filed a support case (#18327)and haven’t received a reply yet. In short - the issue is that out of 3 wyzecams, 1 of the camera is having issue.

Initially when trying to setup, the camera kept saying couldn’t find local network. I was sitting next to the router(and made sure there were no issues on the router(Netgear) and other 2 cameras were working fine) and was try to connect to 2.4ghz network.

Finally after many tries, the camera connected to the network. However, now when I try to view the camera via app - it’s failing after Step1 and its able to go past it only sometimes. If I try for 50times, the app is able to stream the video only 1, rest of the times it fails at Step1 (on app). Please refer the support case mentioned above if you need the MAC address.

I tried deleting the camera and tried re-registration multiple times and was successful only 2-3 times. I also tried using cell phones hotspot(2.4ghz) while registration but kept getting the same error - couldn’t connect to local network. I’m pretty sure the ssid and passwords’ correct.

I had a similar issue with one of my cams when I first got them. I moved to the same room as my router, and tried again. Once I got the camera to connect, I updated the firmware, then power cycled the camera. It’s been good since (not perfect, but not 1/50 ?). I’m in the Beta now, and the reliability is even better.

I have the camera next to the router all the time. The other cameras which are working are not in the same room but still they work fine :). I had filed a support case and got a reply asking to run a network scan (using RouteThis Helps app). I have provided them with the code to look up the logs. I will update this post with their findings.