Wyze Wired doorbell Firmware Beta Test 8/1/2022


What’s New:

  • Improved connection at step 3/3

  • Added connection logs

  • Fixed a detection zone bug

  • Fixed a notification thumbnail bug

[Mod Edit]: Removed embedded space from version numbers to enhance search clarity.


Installed via the Firmware Updates page. Seemed to take a little time, so be patient.

Tried to find the beta firmware update both from the firmware updates page and the device firmware page, can’t find it to test it out on my doorbell that consistently has the stuck on step 3 issue. Advice?

Assuming you are enrolled in the beta program

Make sure you have the doorbell selected for allowance to beta firmware in the Wyze app under

Account>About>Beta Program

Click edit on the top right and make sure the Wyze Doorbell is selected.


Sweet thanks, wasn’t selected so that problem solved. Now fingers crossed for the doorbell!


Still timeouts at step 3/3.
Worked ok for a couple of hours but got stuck overnight.

Setting Night vision mode back to ON (was Auto for this test) to see if that work around still helps.


Still has 3/3 bug…

Log 669379


Continue to encounter failure on step 3 of 3 with new beta

Log 670705


Guess I’m the lucky one, new update still working beautifully for me! Before it would only work for an hour or two and would get stuck on 3/3; I haven’t had this happen once since I updated days ago.


So far 3 days in and it’s been near perfect. It will still at times when going to view the camera it will start out side ways then rotate but it’s much faster. I had one time it errored out when connecting but it’s only been once and it was just after the firmware updated, so far not happened again and it seems like my notifications are actually working again, been getting motion detected a lot due to the trees, but it use to be maybe once every few days.

Also did have a failed to update firmware tried again and it said the update was done in 30 seconds so I think it may have been just a error as it was still updating.

So far this is much improved for me and I’ll keep monitoring it over time.


Which doorbell do you have ?

Was getting a 2205 error when connecting, that’s gone. So now i have a 0 error before it connects. Happened a few times now, it connects and goes to a black screen, 1/3 still hangs, if i leave it be will connect after 2-3 minutes, speedy enough to miss every delivery driver or movement. Will still get stuck at 3 of 3, but less frequently. Motion detection better, but still not fixed. Detection zone still doesn’t work correctly, but seems better. So, after 6 months pretty much same thing, just different errors.
Log ID 671230 doesn’t look like a fix for me. Still seeing constant problems with step 3/3.
Log 670921

1 Like

After applying the Firmware, did you restart the Doorbell? If not, you could go into the app, selectthe doorbell, then settings. Scroll to the bottom and reboot the Doorbell. if that does not work, you can remove one of the wires from the transformer or remove the doorbell, unscrew one of the wires, then reconnect it to restart the doorbell.

Yes, I applied the firmware, power cycled by flipping the circuit breaker, reset the wifi router, and factory reset the doorbell. Still gets stuck on 3/3. Not all the time, but enough to be useless. Toggling through night vision’s on/off gets through the 3/3 sticking issue, but only temporarily.

I will see if I can reproduce it on mine. I have a test doorbell with the latest FW on it.

The normal doorbell just as this update is for.


Still not seeing this update I’m currently on firmware version I’m running the BETA version of the Android app v2.34.0 (b61768). My Video Doorbell is selecting under Account>About>Beta Program.

Doorbell is usable again!

Its been running around 2 days now.

It captures videos now. Previously was hit and miss.

On Android first attempt it sometimes fails error code 20015 on non beta app. A retry has always connected quickly. Have not seen this on the ipad.

The screen rotation does occur on occasion noticed on Android Pixel phone.

Log 672823 Aug 6 9:09 EDT
Closed app
Launch app
Connect to doorbell
Failed quickly. Manual reconnect button
Select manual reconnect button
Connected quickly
Initial orientation was landscape with a quick change to portrait.

1 Like