Wyze Watch 47 Not Pairing (Paper Weight?)

If you’re stuck at QR code, call support and request a replacement. Firmware killed the bluetooth connection. No way to get that back.

Phone: (206) 339-9646
Available Monday - Friday 5 am - 6 pm PT and Saturday 8 am - 4 pm PT

Thanks for replying. I called support but all I get is this long winded monotonous music. No prompt, no announcement and no live person to talk to… Tried few times and stayed on line for hour… Gave up.
This whole thing sucks. I may not buy Wyze again

Failed to pair. Tried restart watch by holding side button. Eventually paired by restarting phone.

Try calling earlier or later in the day when it’s not as busy.

One thing I’d say: make sure you’re choosing the right watch type. I’d ordered a 44 and a 47, Mistakenly choosing a 44 in setup when you’re pairing a 47 will cause exactly this type of behavior (successful binding but then ‘Pairing Failed’ was happening to me repeatedly until I realized I had unboxed my wife’s watch by mistake.)

I was having problems until I updated the app. Try that!

Hey everyone,

I just got my watch today, and I think I found the solution (if it’s been found, apologies, lots of replies here.

For my pixel 3a, I had to give Wyze permission to “Nearby Devices.” in the permissions settings (Android 12). If anyone has a phone with similar settings, that could be the missing puzzle piece for you as well. The second I enabled it, the app and watch instantly found finished pairing in the app, and I was on my way.

Believe it or not this issue comes down to allowing the Wyze app the Nearby Devices permission. (This is NOT mentioned anywhere that I can find on the Wyze support site.)

For the pros:

Nearby Devices

For the non-pros:

Open Settings
Scroll down to Apps & select it
Scroll all the way to Wyze & select it
Select Permissions
Scroll to Nearby Devices & select it
Click on Allow so that the blue dot is selected
You’re done.

I can’t believe Wyze hasn’t figured this out and published it yet!

I found the solution to both my iPhone 13 and Samsung Galaxy tablet. If you have done a factory reset and it still fails to connect, check your iPhone and Andriod Bluetooth settings and remove the Bluetooth device (aka forget device).

For Andriod devices, you can try to re-establish the Bluetooth pair connection but for the iPhone, you’ll need to go through the Wyze app for the new device setup again. Hope this helps!

I fixed my pairing issue someone listed below. Forget device on bluetooth and boom you can pair again