Wyze Thermostat Not working

Hello- we are trying to install a wyze thermostat and we are having issues. We had the nest prior so the wiring is the same. Initially we got it wired and went through the app and it said remove extra wires. There are no extra wires in any of the ports it is saying. I tried starting the install again and now it won’t even recognize the thermostat. Of course we can’t reinstall our nest because one of the buttons broke off during removal. What can we do to get this working.

It is just stuck in the wyze screen and I can’t get any further. So frustrated!

Wiring looks ok at Tstat.

Ios or Android? App version.
Tstat firmware version. Hope there was no interruption dyring Tstat updating.

Tried fsctory reset Tstat?

Keep trying when it tells you that there are extra wires and eventually it will let you skip this error.
If you cant get it to recognize the thermostat from the app, hold down the button on the thermostat until it asks you if you want to reset it and then select yes.