Wyze Thermostat latest firmware issue

Neither of mine are AND I try turning on presence detection, which also didn’t work.
And to correct my mistake above, firmware version is 1.1.8

I’m on the same firmware, but probably different app versions. I don’t see a setting for presence detection, it’s typically a automatic feature.

The presence detection in 1.6.2 of Android app might be new, I don’t recall seeing it before, but it enables phone location and other Wyze devices to determine if home/away. I don’t want to use (phone location) this as it runs constantly in the background AND it would require my family all to have the app installed. I want the simplicity of motion sensing on the thermostat to work as it did, since that’s is what my schedules are built around.

I can confirm that having away mode in a schedule seems to be broke with this latest firmware update. The thermostat display comes on when you walk by, but the mode doesn’t change like it did in the prior firmware (switch from away to home). I didn’t try manually putting it in away mode like Ken did to see if it comes out when not in a schedule; I will confirm the results of that when I have a chance.

I “spoke” with support this AM. They are looking into the issue.
Worth noting: when you submit a log, you are sent an email thanking you and instructing you to “connect with a member of our team” which I took to mean support.
Support sez…“My team here in support does not review your log or follow its progress. We’re working on developing a process so that we can track these logs on our end, but it’s still very much in progress. We hope to have the ability to receive more details from your log submissions soon.”

Same issue for me. Mode does not switch from Away to Home if you walk by the stat, like it used to. Screen does light up however, so motion is detected. Issue exists since 1.1.8 fw upgrade. I also do not want to use Auto Switch option based on phones location–useful for some people I’m sure, just not what I’d like.

Agree senses motion (as screen lights up) but doesn’t change mode.
I also do NOT want to use autoswitch…though it didn’t work for me either.

FYI all, this is what support has told me to try, which I won’t be able to do for a few days…
“Please perform a factory reset on the device.
To reset your Wyze Thermostat, press and hold the control wheel for 10 seconds. After that, delete the Wyze Thermostat from the Wyze app and set it up as a new device.”

Interestingly, I tried manually switching to away and then walked in front of it and as was mentioned by Ken, it does switch to home. So the problem seems to be isolated to state switching within schedules.

Update to app was to fix this issue. I tested it yesterday and seemed to work. Today, doesn’t work. Additionally, as I was rebuilding my schedule to include Away multiple times, I realized I couldn’t add 2 Away’s in a row. My previous method was to switch the thermostats to Away every few hours during the day. Worked great…now doesn’t work at all :cry:

Same issue on mine. Both presence detection and geofencing stopped working. These are the selling features for this device.

I completely agree…even though I didn’t realize they had these features when I bought, the presence detection via motion sensing quickly became one of my favorite things.

Support seemed to think the app update fixed/would fix it (didn’t), but seems to be to be a firmware issue.
Still waiting on a fix.

I just got this terrible response from support:

“I got an update from the engineers that the new logic of Auto Switch can only be triggered by the phone’s location. That is to say that the PIR sensor will not trigger Home when movement is detected at home. What the PIR does is to resume your Schedule when movement is detected”

I’m not really sure what “resume your Schedule” means

So this is a new feature of this SMART device?

Something else I just discovered that I find odd.
I have the thermostats in Away mode.
We all know, motion doesn’t change state from Away to Home like it used to (and should still), but I also discovered that if I walk up to the thermostat and manually change the temp…nothing happens…it is still in Away mode.
That is another time the thermostat state should change from Away to Home - when a manual temp adjustment is made on the thermostat itself.

Ok folks, I’m finally getting somewhere…but not real happy with where it is I’m getting (going?).
I’ve been dealing with support for about a month on this.

Finally…FINALLY I have somebody say the reason the motion sensing (PIR) trigger that changes the state from Away to Home was disabled on purpose.
There were too many complaints about false triggers.

I would truly love to hear from folks who complained about this and how this was a problem for you.

For you others that actually liked this function (like me), all I can imagine is we need to be very vocal about wanting the functionality back.

And here’s the deal, it could be done as a rule in the app, that is fine, but this needs to be a function of the thermostat as it was before.

If complaints about false triggers was a big problem I would expect there would have been some complaints on this forum but I haven’t seen any. And I go back to my suggestion about just making it a user selective option if you want the PIR to trigger state changes or not. I was using the function so I would like it back.

1 Like

Well thanks for the update and getting to the bottom of this. I agree, bring the functionality back. Even if it needs to be enabled in a setting. That’s fine. The hardware is capable of it, let it do it.

1 Like

Can a Wyze Employee confirm this? I don’t think they took any feature away. I am on firmware 1.1.8 and it works perfectly fine for me.

There have been no other complaints about this as someone else mentioned. Nor has there been anything in the firmware notes about this.

Who was this somebody that confirmed something was turned off? Support?

I confirmed it with support.
They turned off the motion sensor (PIR) changing the state from Away to Home.
IF you were using Auto Switch, which using geo fencing, that still works.
BUT - the motion sensor on the thermostat is essentially disabled.
It will “resume schedule”, though I’ve yet to confirm what that really means.