Wyze Thermostat Away Function

Isn’t working. Worked once but now not working when myself and phone are away. Does not turn down the heat like it is set for.

Welcome to the forum! @Maineiac

When you set your thermostat to away , is the mode sticking ? Or does it change it to another mode ?

I’m experiencing something similar , whenever I put the thermostat to away mode a lot of the time the action won’t stick and it’ll change it to sleep mode automatically or if after I set it to away mode and I walk in front of the thermostat it’ll change it to sleep mode . Really strange behavior

Welcome to the Wyze User Community Forum @Maineiac! :raising_hand_man:

It sounds like you are trying to use the Auto Switch Geolocation \ Geofencing function in the settings to change the thermostat state based on your phones GPS location.

I don’t use that feature for several reasons. Many have reported unreliability with the App’s GPS Geolocation \ Geofencing capability across multiple devices and within programmed rules. Others have indicated that it doesn’t work unless the app is open on the phone. Still others report it working on entrance but not exit.

There seems to be an OS issue of killing the background process from the app that is required for this to communicate with the phone’s GPS.

You can try to force the app to maintain a background presence by toggling on the “Running in the Background” toggle in Account, App Settings… But no guarantees.

1 Like

It seems to work if I manually set it to away but I’m trying to use the Auto Switch function that is in Settings so that the thermostat will automatically switch to Away based on my phones location.

I have the app set to run in the background. I’ve tried this 3 times, the 2nd time worked but the other 2 didn’t.