Wyze Sprinkler Set up Issue

I would like to start off that I own a great deal of Wyze products and have never had issues getting any of them set up.
I received my Wyze Sprinkler a while back but since it was winter I held off from installing as my system was/is still winterized. I decided it was getting close to time to start watering so i went ahead and started installing it. During my first setup everything registered correctly and was going smoothly until after completing the installation it asked to do a firmware update. I ran the update and it subsequently failed. At that point the Controller would not respond to anything I tried. So I was able to delete it from my Wyze account and use the reset button to put it back into pairing mode. I tried setting it up again and from here on out everytime i get to pairing my phone with it and setting up the wifi it gets stuck on the screen (attached) and there is a spinning wheel next to “Connecting to Wyze Cloud”. If anyone knows the cause and/or solution to this please let me know.

1 Like

I’m having the exactly same issue.

I have the same issue after replacing my wifi gateway.
All of my other devices connected with no issues.
Had to delete the control and reset it.
Now it wont reconnect I get the same screen and fails to connect.
I’ve tried all the suggestions on this forum and others none work.
Wyze needs to step up and give us answers or send in new controls.