Wyze Sense History not displaying correctly

I just noticed the event history of my Wyze sense devices (motion sensors and contact sensors) are not displaying correctly.

When I click into one of the device, the event history does not show the latest. It would show “Yesterday” and the days before. It is reporting “current” events correctly in the status, so at least I know it is sensing stuff and not a battery issue. For some of them, it takes a few seconds (like 5 seconds or more) for it to show the latest history. for some others, it just wouldn’t show the latest.

Any idea? Thank you!

1 Like

I’m having the same issue and now having to reset the camera every few days or else the bridge stops receiving things from the sensors

I even delete and add back one of the sensor, thinking that it would reset that sensor and remove the event history, but it did not!

Is it because of the new cam firmware?

@NAMARTLU The sensor history is stored on the Wyze server, not on the sensor.

1 Like

Yeah I figured after reinstalling the app, still not helping. Weird thing though is that the event lists are not the same on my iPad vs my phone, how could that happen!?

Need more info to be able to troubleshoot. How are they different? Same login or different for each device? Shared devices?

That IS a head scratcher! Have you tried an older version of the Android app to see if that version works correctly? I just checked my contact sensor and it works correctly … my setup:
Android app v2.9.30, contact sensor plugin version, bridge firmware, camera v2 firmware
I did not test the motion sensor.

I think now all the sensors stopped showing status, no notifications, all dead. I probably need to submit a ticket. Is there any way to reset the bridge, or it won’t help? I tried turning off the cam and unplug the bridge, plug it in again and turn on cam, but it doesn’t help either.

This thread might be similar to your problem:


sounds exactly like my problem… sigh… seems like either roll back both cam firmware and app (to non-beta)… or wait for a fix…