Wyze Robot Vacuum Setup Issue - 1/25/21

Same here. Doesn’t work.

1 Like

I just tried 2.17.21. Tried several times via the normal setup method. Every time after I joined the vacuum’s WiFi my vacuum successfully connected to my home’s SSID. But then hangs and never communicates with the app. I tried factory resetting. Still nothing. I tried powering down. Still nothing. The robot makes it to where it needs to go and shows up as online on my access point. It just never finishes setup with the app.

I am running Ubiquiti Unifi APs and router at home. My internet provider is AT&T Gigapower. What network and ISP provider configs are others running?

Is it possible there is some message that could be filtered that might prevent the setup? I’m not filtering anything locally but I have seen examples of AT&T filtering funny things like NTP before. Wyze, could we be hitting something like this?


1 Like

Its not something broken on your network. It’s an issue wyze has to fix.

1 Like

I’m not saying broken. I’m saying filtered. For example I have water leak detectors from Honeywell. Due to AT&T filtering NTP packets they would not come online either. NTP is what some devices use to get their time of day. And Honeywell firmware must have been written to require this before completing registration. I had to put in a complex hack on my router to tunnel these through the AT&T network since AT&T refused to change it. I’m just asking Wyze if they do anything similar. This issue just seems eerily familiar to that with only some people not able to come online.


Same issue here.

1 Like

I think this is a good thought but it seems way too mainstream with many different routers and ISPs and users to seem like it would be the cause. But who knows? Apparently nobody.
I’ve setup a few different Wyze products with no trouble in the past, and lots of other smart products with no real brand name.

1 Like

Further, we’ve found some success for some people with restarting their vacuums. If you cannot see the Wyze Robot Vacuum WiFi broadcast during setup, please remove the Wyze Robot Vacuum from the charging station and then press and hold the power button on the vacuum for 5 seconds. This should restart the vacuum and the WiFi broadcast should appear again during the setup process.

So I just saw this as an update from the development team. There is a problem with this new guide and they should pay attention to it asap. When you press and hold the power button on the vacuum for 5 seconds it does not restart the robot!. Before it even reaches 5 seconds, it shuts down the vacuum. Then you have to hold the power button to turn it on. I tried this and the robot’s Wi-Fi did not turn back on. There should be a clarification on this. If I hold the home button for 5 seconds it asks me to factory reset the robot. 5 seconds on power always shuts downs the robot. Factory reset also does not turn the wifi back on. Only wifi reset turns the wifi back on.


This has nothing to do with SSID. I grabbed this robot and took it to my in laws house today with a complete different setup. The robot stills drops the wifi on the phone and connection fails. I am not sure why the app or phone does not pick up the robot but I can see it as * with a mac address on the router. This happens at home and at my in laws. Obviously an issue with the app and the robot not your SSID. I removed symbols, I switched everything off, removed every device from my network. Just chose the most simple names and am using 2.4ghz. No difference. App connects to my internet, asks to connect to robot, it connects and the robot’s wifi disappears.


The vacuum firmware doesnt know how to get to the wyze servers. Their provider AWS changed things. The vacuums in shipping didn’t get firmware that had the changes.

1 Like

Hard reset is to hold home button for 5 seconds…then once it starts talking let off button the immediately hold again for 5 seconds and ot will reset device.

I’ve updated my wyze beta app and tried multiple angles to get this going…still nothing.

1 Like

So probably have to ship back?

I’m hoping not.

Here is a link to the post by WyzeGwendolyn: (App certificate update & WiFi broadcast)

Tried @WyzeGwendolyn suggestion…it was a no go…give me the ability to update vacuum with micro USB on bottom…this thing won’t connect to wifi

1 Like

Or… we actually already had the vacuums connected to WiFi. We could update via that.

I received the vacuum today installed the app on my pixel 3a, updated the firmware and was able to run the vacuum without any issue. After a couple of hours, the app showed there was an update which I installed too. My only wish is for the app/vacuum to allow multiple maps (my split level house has 4 levels) and spot cleaning.

1 Like

I am having the same issue. Tried 2 different routers and 2 different phones. Exact same issue as many have stated above. Hopefully a fix will come quickly.


I’m on Android with the same issues as everyone else.

Going to try to give as much detail as possible…

App: Newest version of the Beta app (2.17.7)
Phone: Pixel 4a running Android 11 with the January 5th security update and the December 1st Google Play system update
Wifi: eero model # B010001 for the main router (which should be the unit the vacuum is connecting to because it’s right next to it)
Wifi names and passwords do not have numbers or symbols…I know. I’m asking for people to hack me. Please don’t.
I’m blanking on additional info that might be useful…

I’ve tried holding both buttons down while connected to the charger, holding both down while away from the charger, resetting, turning on/off mobile connection, resetting router… all things mentioned in this thread. When I go from the app to change the wifi connection to the WVCR connection and then back to the app, it sits and acts like it wants to connect but nothing happens. when I go back to view the wifi connection available, the WVCR connection is gone. It’s almost automatic. I can connect to it, go back to the app, and immediately go back to wifi connections and it’s missing and my phone has reconnected to eero wifi. Something has to be happening when we go from our list of available wifi networks (and connecting to WVCR…) back to the app. As soon as I’m back in the app, the wifi signal from the vacuum stops. Don’t know what that means but… Hopeful someone on the WYZE team does…

If more information is needed to diagnose and fix the problram, I’d be happy to provide whatever you need (not my SSN…)


Just received my Vacuum today. Having similar issues as everyone else.

  1. Start the app.
  2. Add Device
  3. Robot Vacuum
  4. Push Home and Power to reset wifi as instructed. Ensure Phone Mobile data is off and connected to preferred home wifi network.
  5. Enter Wifi network PW.
  6. Connect to Wyze Robot Vacuum

This is where things seem to go off the rails.
7. The moment I move back to the wyze app. It states connecting then It drops the Wyze Robot Wifi…
( I have tried turning all auto-reconnects off, tried all other options) If I leave auto-reconnect on it goes back to my primary wifi connection. Hangs on connecting… and eventually fails and asks for Wifi PW again… and restarts back at step 5.

Having many other Wyze devices it seems as if the moment the Wyze Robot Vacuum is getting the wifi information but never finishing the setup processes. I hope this information can help debug the issue.

[edit] - I also have the most up to date version of the Wyze App on Android

1 Like

That’s great @sambition. Please share your entire set up with the group if you don’t mind, from setting the wifi up on the robot without it dropping out it, to the rest of the steps. Maybe we are doing something wrong or we all need to get a pixel 3 and try. Anything can help right now. You are like the 1st person to successfully set up after receiving the robot post Jan 22 deadline firmware issue. So out of…I don’t know Maybe 100 customers on here with the same issue you my friend need to play the lottery today. But congrats on getting yours to work.