Wyze robot vacuum - map editing & additional enhancements

I believe that to be true. It does not appear you can do a quick map if mapping has already been completed.

One issue with room editor is you cannot split a room who you always want. You can only pin the room walls to certain places on the map, not sure why I cannot pin it to wherever I want. In some cases the app will not let me pin it to one side of a door opening only the other side.

I have the following issues with room. When I select rooms to vacuum most of times it works and it vacuums them. Sometimes it does the whole house instead and sometimes it just randomly vacuums and returns to charger. Also schedule cleans I select rooms to vacuum and then save and then go back in and my rooms I selected have changed back to whole house, etc. Anyone else seeing and have tips?

I was having this issue almost every day last week. I finally cleared all my scheduled cleanings, and re-entered them. Since then it only cleans the room (or rooms) it is supposed to. I did not re-map the house (that takes too long, although I am tempted).

Yeah, mine has been working very well since I remapped for the 5th time. Schedules seem to run well, as well as area cleaning. I just wish now that they would add a zone cleaning option. Like if you dropped a bunch of crumbs under the desk and you just want it to clean that area rather than the whole room.

You can vote here. This is wish item exactly for that same thing!


Based on multiple people having issues with scheduled cleanings for a single room, but it being resolved by rescheduling, I think what is happening is scheduled cleanings don’t update correctly if the room assignment changes (could be by splitting or combining rooms, or could be by wyze updating the map and getting rid of a room that existed before.
@WyzeGwendolyn, is this a know issue? I would assume the expected behavior would be:

  • if a room is split, any scheduled cleanings of that room should now clean the 2 newly created rooms
  • if 2 rooms are joined, any scheduled cleanings of either of the rooms should clean the newly joined room
  • if the vacuum removes a room (which it should probably never do but I’ve seen it happen), any scheduled cleaning that contained that room should just remove that room from the cleaning (or remove the cleaning if that was the only room)
  • if the vacuum adds a new room (not sure if this can happen yet, but should happen in the future when implemented), this shouldn’t affect any cleanings.

I don’t expect for name changes of rooms affect cleanings. Also don’t think if you update one room that a cleaning of another room should be affected, but if either of this is the case that should also be handled. Also re-mapping should probably clear all schedules (don’t know if it does or not), would be nice later if it can recognize which rooms were the same for the remapping and correctly reasign those rooms and keep those schedules, but that’s probably a later feature. Hopefully we get to a point where remapping is only used when you are moving to a brand new unconnected space, in which case it would be a non-issue.

I would like the ability to specify a specific room for the robot to remap or update. I noticed an odd deadzone in the cleaning map the other day before I realized it was where a piece of furniture had been sitting when I first mapped the room. The robot couldn’t see under or behind it so it had mapped that as part of the wall of the room. I had to remap the entire house to eliminate the deadline (which also resulted in having to re-do the scheduled cleanings). Alternatively making the map a little more “flexible” while the robot cleans (i.e. the map will update and refine with each cleaning up to a certain percentage of change) could also solve this issue.


Yeah, agree. Like area cleaning, there should be area re-mapping. Where bot will just go to those areas and do re- map or update map

1 Like

FYI, seems like resetting the map resolved the issues I was seeing w/ the ‘turned base and maps’. I’ve run several scheduled cleanings since and, so far, no issues after deleting the map, quick mapping and then creating new schedules. I also haven’t seen the return of the lidar timing out for a bit but too early to tell considering this a 2 event random issue.


Same issue again this morning - lidar timed out and map turned.

back to waiting on support for next steps.

Maybe it’s a hardware issue…

Agreed, that’s what I’m expecting at this point considering the 3rd recurrence after resetting the map twice.

I kinda hate to suggest it, but maybe resetting the map and remapping the slow way would do something. Mine has been working perfectly after remapping this last time. I too hade the angled maps forming as an overlay. Bugt I have never had the lidar issue. That’s what makes me think it could be the hardware…

You dont have to request update. There is an option to reset map (not remap, reset map) that will delete the old map. Then click on clean and it should work the same old slow way … try it

I’m seeing this as well. Does a great job not banging into things. Our Roomba beat up the house and walls a lot. But every once in a while a “Full Edges” mode would help get into some of the kitchen edges and the edges of the couch. Would also love a way to identify something as a couch. That way it could go under there on some runs. Love this product so much!

Significant improvement!
I deleted old maps and schedules.
Did the quick map and then split rooms [splitting is still a bit convoluted]
Re-entered the schedules.
So far it has been perfect…cleans [very well—seems to pick up so much more than the old Roomba or Iclebo] as scheduled. Has not gotten lost or become disconnected from wifi. Has not gotten stuck under things…thanks to the red room edit boxes.
It now appears to be working as planned.
Fingers crossed

It! I’m back to this again after a full week of flawless operation. I got the lidar blocked message and then the crooked map. I tried again but it didn’t get even a foot off the base before it freaked out. I don’t see anything blocking the lidar, or even any dirt…
Come on Wyze, get this fixed before you see a bunch of return requests.

Here’s what happened when I tried again. It wants to angle the room, but follows the direction of the original map in the middle.
So freaking frustrated that I have to delete the map and start over again.

The same thing happened to me. The room turned at an angle and robot didn’t believe where the charger was. The quick map feature was nice tho and my frustration was quelled easily. It remapped and I reset rooms in less than 10 mins. Don’t want to do it all the time, but is q relatively quick fix.