WYZE Plug Failed to add

Dear support or community.

I run into the problem of configuring the WYZE plug model WLPP1. I think the problem related to the latest firmware or app update. It was working for a little a year since I bought it. I don’t recall the WYZE app or firmware updated now I can not add it to the device list. When I tried to add a new device it was able to take me all the way to connect to the device wireless. After the connection was successful and next screen was waiting to complete the setup. It ran for a while and return with connection failure. I have tried many many times but still could not get it to connect. Is it be a device failure or firmware issue? The plug is still working with manual turn on/off from the device switch but I can not use the wireless function anymore. It is over a year so it is out of warranty. Let me know if you have any suggestions to fix this?


is your mobile data off while you are doing the setup?

I remember having bought a plug after about a year of not setting one up I ran into this issue as well and it turned out that I had forgotten in the long time of not setting on up that you have to turn mobile data off during the setup or it hits the connection wrong and fails each time. I felt like an idiot might it be something that simple with you as well? it is more than understandable :slight_smile:

Yes I tried that too and it did n’t work