Wyze Finally Works With Google Assistant!

your roku tv can be controlled somewhat by the GA depending on the model but there is no current ROKU wyze app.
currently to stream the wyze cam feed you would need to have a device like chromcast or apple tv hooked up to your TV
the “works with google assistant” is for streaming to google smart screen devices or to chromcast
this isn’t working well currently
the android and ios apps work very well however


I have Android Note 9, GOOGLE home mini, and Alexa through my ecobee smart thermostat.

We’re working on this with all involved parties (Google is also adjusting things from their end) and we’re trying to sort this out. We’re sorry that it still isn’t working right for some folks.

1 Like

I’m sure it will happen when it’s supposed to

Why did they claim that it work with Google when you purchase the cameras?

Fwiw … the latest v2 firmware update ( seems to have corrected the buffering problem, in my particular case anyway. Working perfectly.


Nice! I remotely upgraded my cameras yesterday but forgot to check when I got home. If I remember I’ll report back on my JBL Link View connecting when I get home.

1 Like

Please let me know how the new firmware performs for you! All companies involved have made some changes to improve the streaming through Google Assistant and we’re hearing positive results so far. :slight_smile:

It seems to be working 50% better. It took around 12 seconds to load but then after about 15 seconds went into a loop of showing the controls then back to on.

1 Like

Well, that’s progress at least. 12 seconds to load is about what is expected. The control loop is interesting. Did that happen again?

How and when do we get the new firmware ?

Nest Hub + Cam Pan

  • takes around 40s to start streaming something
  • after video shows, it has a 25s delay.

No. It’s still not working at all. Continuing to get Google Assistant saying “It looks like the stream is unavailable.” I have re-booted all the devices. It’s been months, literally months, since anything has worked at all … always the same ‘stream is unavailable’ message.

A 12 second delay in the load time is what is expected!!! Are you serious? Connection to my Amazon Show 5 is only 5 seconds and that seems inordinately long given the speed of responses I get for my other devices; locks, lighting brightness/colour changes, on/off devices, radio streaming all happen on the order of 1 second.

It’s really time to get this thing working. From my perspective as a consumer who purchased my cameras explicitly because of the Google streaming more than 6 months ago this has been a TOTAL disaster.

loaded the firmware today on 4 v2 and 2 pan cam
you must unlink wyze in the google home app then relink it in the google home app to work (which by the way is very tedious for every firmware update since you the have to reassign all wyze devices to rooms in the google home)
if you don’t you get the unavailable message…
after above the load time is 19-23 seconds
much less buffering afterward but still buffers occasionally
seems to buffer more on the pan cam but will see over time
average of 20+ seconds still too long for checking who’s at the front door
better but still not fabulous
needs to stream locally for it to work properly with doorbell

Yea and on more than one device, google nest hub and hub max

You could buy the nest cameras. They’d only cost like 4x as much each. Other option is to wait patiently for this integration to get fully fixed. Google also has some part in this too.

Like @jflmd mentioned, you have to unlink and link Wyze with Google agsin.

Still not working now i did’nt see anything only a message on a white background ‘’ Streaming is currently not available’’ …

Remove and re-add Wyze from/to your Google assistant.

Done, Now I just see a black screen …