Wyze Finally Works With Google Assistant!

Has anyone have a problem with the video feed not loading or taking a few minutes to load on the Google nest hub. It wasn’t do this before.

Yes yesterday I could not get any to show. Google didn’t say it couldn’t but video never loaded just sat there. Just tried again. No picture but google said, oh wait after 30 seconds it finally came on. That lag is definitely problematic

Hi there

I am having the same trouble with “it looks like the stream is currently unavailable”, I submitted my ticket today.


1 Like

Any plan to support the stream directly from the Google Home app? (Is it even possible?)

TL;DR is: we have a full plate for the moment and can’t tackle those extra camera features yet but it is our intent to add them.

Right now, we are working on getting a large set of hardware on the platform. Once we stabilized that point, we will start backfilling the features of the camera. We also have some important work coming to try to reduce the latency of the camera experience. We have a dependency on the implementation of WebRTC and this is going to take some time (~early 2020).
We are finishing the work associated with the authentication in the system, which should give us greater reliability in getting the Google Home to connect to the camera…


A post was merged into an existing topic: Wyze Home Google home/assistant Sync

Getting “ looks like the stream is currently unavailable “ message from google hub. Unlinked and linked again with no luck.

Any solutions yet

Usually unlinking and relinking works. Here are a couple of places you can look for information on how to troubleshoot this more.


(Keep in mind that this forum is primarily a user to user community. If you don’t get a helpful reply here, please file a Support Request. You can also submit a request from within the Wyze app by going to Account > Help & Feedback > Report an Issue. The latter method will allow you to include an app log for diagnosis.)


Sorry about that, @dianatrinh07! Are you still running into this problem?

I need to unlink and relink a couple times a month, because otherwise anytime I try to command one of my cams it says Wyze is not available. :disappointed:

Hi Wyze

Yes I’m still having the problem with the google hub not connecting to Wyze with the same error “ the stream is not available right now “

Same here. Doesn’t seem to be a problem exclusive to Wyze though. Other devices that “support Google Assistant” require the same unlinking/linking periodically. Very annoying.

Until this encoding delay is resolved the assistant is pretty useless, so I’m not too worried about it.

1 Like

@dianatrinh07, I’d recommend contacting our support team so we can run through some troubleshooting with you. We apologize for the trouble.

Support Request Form

@FezVrasta, we’re sorry you keep having to do that. I’ll tell the team.

1 Like

Is there any update on this? I keep having this issue :frowning:

I’m sorry, I don’t have an update yet. But I’ll tell the team this is still a problem for you.

I too had the same issue as @FezVrasta, but now it takes a long time for the stream to play on my chromecast or Google Hub.

Could you give an estimate for how many seconds you think it’s taking?

After the voice command, the screen will go black. Counting from here is ~20secs, then some reverse progress bar appears along with a loading spinner, then it’s about another 30-40secs.

1 Like

Do you have any delay opening your live stream in the Wyze app? About 10 seconds is the minimum expected delay for Google Assistant.

So, before today, I’d never succesfully gotten the stream working on Chromecast. I had the same issue @louie1487 reports. I just tried it again and it DID finally show me the camera stream, but only after waiting more than 2 minutes. (It may just be that I never waited long enough before.) The stream only worked for about 90 seconds before it went back to the buffering screen like before (except with a frozen video instead of the black screen)

1 Like