Wyze doorbell (March 30 2022) - unusable/slow connection & streaming

And that was almost 3 months ago. Ridiculous that they have figured this out and fixed it yet!

They did come out with a new scale though lol.


While we wait and wait I’ve noticed when the issue happens removing or adding cam plus jogs it into working. Of course useless if a motion event or notification is not sent. And it takes time if the doorbell rings.

Same issue here log submitted.

Log ID: 614114

My main issue is live view. It doesn’t work. Its always an authentication issue or if it does connect, its only for a minute or so. Meanwhile the whole time it’s capturing motion because I see the notifications come in, But even clicking those don’t work. Its not a router issue. Its something on their end. End of story.

Are y’all watching the Fix-it Friday thread w\ weekly updates?

I’ve fixed the issue on my own.

DO NOT remove or delete the doorbell camera from my devices on your app.

I started by removing my 5G network connection completely from my device ”forget this network” (routername_5G or just Routername)

I then made my 2.4 network or Guest network as my only connected wifi network.

I deleted all the cache from the app on the Doorbell Cam.

On the doorbell cam I held the reset button for almost 2 minutes.

On the doorbell cam I scanned my new QR Scan code the app populates when connecting a new device.


When I preadded my doorbell cam as a new device I renamed it “Doorbell Cam New” in order to later identify the reconfigured cam.

completed all the connection process and added the chimes.

I fully verified the doorbell cam was 100% functional on the app and verified livestream was 100% functional.


The doorbell has been working for 3 weeks now no issue.

1 Like

Anyone else try this?

I have not, but I have two original doorbells (front and back). Bought same day, installed same day. Always worked fine. After the update(s) the front has continued to work fine. The back has been messed up since the .42 update. It’s actually online more often now as my yard is wooded and as long as the leaves are blowing it keeps the doorbell awake. I have no reason to think that one doorbell would be affected any differently (network connectivity wise) than the other so I am doubtful.

I haven’t but this is definitely a Wyze problem and they are aware of it and working on the fix. Until then, I just keep waiting.

Good luck peeps. I’ve returned this camera and not coming back. Glad I purchased the 2 year warranty on this. The camera literally stopped connecting to my network. I’ve reset it over and over and the thing would not connect. Im done, too much of hassle to get this to work as it should. I hope the firmware fix is soon for you guys.

1 Like

Yes I have the same 3/3 problem after FW upgrade. I’m using the Greet video doorbell just to fill the void.

In my case the online icon (ON) not show up by the thumb nail. It can produce life feed when it is motion triggered.

In an attempt to fix this problem, I reset it, delete from App, delete it from my router, add in Wyze App again. Since then it fail to login my router consistently.

Same issue. FW

Log # 636733


Similar issue here. I’m getting stuck on step three of “Authenticating”. This is happening in both the production and beta apps. Ironically, when it does connect, I’m getting excellent transfer speeds between 100-200kb.

Fortunately we have one month due expiration of this doorbell. Thanks to Wyze and their support team, a replacement unit is on our way.

Yes I agree this piece of hardware is great, it has color HD under our porch light and portrait aspect ratio not found in big boy’s models and doesn’t use a battery. It has the smallest footprint on the market. Looks more like a push button than an intimidating camera. Before we call support we shop around have found nothing that caught our attention other than this doorbell and it only cost about $40. We’ll buy this model again beyond the next due expiration.

Update: Doorbell cam seems to be working perfectly now. I can access it no problem and it connects quickly. Not sure what changed, but it works well now!

Is an update on the current status of this issue available?

Beta firmware seems to be vastly improved. Over the past day I only ran into one case where it hung at step 3 of 3m but the hang was much shorter than what I experienced before.

1 Like

Thanks for the heads up, is working much better. Couple of times in the Android app it came up unable to connect quickly, retrying it connected. Not sure it that was the phone\app, but at least it connected quickly the 2nd try.

1 Like

I’m still at and it tells me my firmware is up to date. Still having the same problems being stuck.