Wyze Cams Can't Maintain Connection After Switching to Ubiquiti AmpliFi Alien

TL;DR: Is there some weird compatibility issue with Wyze cameras and Ubiquiti’s AP’s? Before I go super crazy trying to troubleshoot this, I’m hoping to gain some experience from others in the community about this. Some basic details:

  • Wyze v2 Cams Firmware
  • Wyze Doorbell Firmware
  • Ubiquiti AmpliFi Alien Router Software Version 3.5.2 revision 78-0-g172cd9b827

Long Version: For some time now I’ve been successfully running a handful of Wyze Cam v2’s and a Wyze Doorbell on my WiFi network powered by Comcast’s/Xfinity’s xFi Gateway 3rd Gen (XB7) gateway. I did not have a special setup with vlans etc.; just a basically out of box configuration. Up until yesterday evening, everything has been working fine.

However, because the quality of the WiFi signal wasn’t great in certain areas, I’ve been wanting to switch to a different WiFi solution. I’ve been looking at some UniFi WiFi 6 AP’s to complement the UDM Pro that’s on it’s way, but since stock has been out for quite some time, I decided to settle on Ubiquiti’s AmpliFi Alien router. I installed the Alien yesterday evening and although WiFi is working, I’m now having trouble with all of my Wyze cameras.

For starters, within the Wyze app most of the camera’s cycle between being online & offline. When they’re online it takes a really long time to actually display the feed stalling at each step for several seconds. I wasn’t seeing or experiencing this on Comcast’s/Xtinify’s hardware.

Also, I’ve been using tinycampro on a Chromecast with Google TV with great success: Live feeds of the Wyze cams load quickly and are cycling through without issue. After installing the Alien, virtually none of the camera’s display within tinycampro and they almost always show up as either:

  • P2P camera offline
  • P2P failed to start session (AV_ER_IOTC_CHANNEL_IN_USED)

Again, on Comcast’s/Xfinity’s hardware, everything has been working fine for quite some time. As soon as I switched to the Ubiquiti AmpliFi Alien yesterday, I ran into these issues.

I’m going to reposition the Alien later today to see if that helps, but before I go any further I figured I would try to solicit feedback from the community.

Any chance you ever got an answer on this? Im having a similar issue after jumping to an Amplifi Alien

Hi there @mikedavidson & thanks for taking the time to reply.

I troubleshot this extensively on my own and provided Wyze with the details they asked for but I never got this fixed per-se. I actually posted in the Amplifi community forums here:
AmpliFi Community

Although that has been decommissioned, a cached copy exists here:
[SOLVED] Wyze Cams Can’t Maintain Connection After Installing Alien | AmpliFi (bingj.com)

I returned the Amplifi Alien because I just needed something that would work and my single several years old Google home AP worked great.

What I can tell you is that since then I have continued to run into connectivity issues with my cameras. They frequently just don’t connect and an unplug/replug rarely solves the issue. When I asked Wyze support about this they said:

The v3 and Pan Cam v2 have upgraded connectivity hardware, so their ability to find and maintain connectivity to a network is greater than the v2. Since you have a mesh network, it could be that the v2 is closer to a 5.8ghz node. You can move the v2 closer to a 2.4ghz node or change the SSID of one of the 2.4ghz nodes and connect the v2 solely to that network.

While I fully appreciate the hardware differences between v3, Pan v2 and v2, it was at the time a relatively new issue only cropping up within the last few months. From a network setup perspective:

  1. I have two Ubiquiti U6-LR’s Access Point U6 Long-Range – Ubiquiti Inc.
  2. Each has separate 5Ghz MU-MIMO and 2.4Gh MIMO radios
  3. The 5Ghz band has different SSID than the 2.4Ghz band
  4. The cameras are on a dedicated SSID which is specifically for the 2.4Ghz band.
  5. All of the other devices are on the dedicated SSID for the 5Ghz band and are not configured to connect to the dedicated camera SSID on the 2.4Ghz.
  6. I have 2 v2 cams literally within 10 unobstructed feet of the AP and they face this issue. I even moved a third camera to within 4 or so feet of the AP and it still didn’t connect.

At the time I had this setup for about a year and it has been working well. Again, it was only in the last few months when things started getting a little strange. I’m open to the possibility that it could have been updates for the AP’s but there aren’t many and I apply them manually. But I can tell you unequivocally that nearly every time there’s a firmware update for the cameras, they almost never succeed on the first try and require manual remediation up to and including a reset.

What works 100% of the time for getting these cameras functional:

  1. Pressing setup and re-adding the camera via the app
  2. Factory resetting the camera and re-adding it via the app.

I’m struggling to wrap my head around why, if there’s some sort of signal-based connectivity issue, it doesn’t work when I plug it in and it boots up, but works fine 1 minute later after going through the setup again. Surely the network is not suddenly fixing itself the moment I complete the setup, right? It feels like the camera’s are just forgetting the WiFi network details.

What I have done since then which has marginally helped:

  1. Setup a unique SSID on each AP for the cameras they will service.
    1a. For the AP on the first floor, I created an SSID like “Cameras for First Floor” on the 2.4Ghz band only.
    1b. For the AP on the second floor, I created an SSID like “Cameras for Second Floor” on the 2.4Ghz band only.
  2. Joined all the cameras on the first floor to the “Cameras for First Floor” SSID
  3. Joined all the cameras on the second floor to the “Cameras for Second Floor” SSID
    So instead of running into this issue daily, every few days, once or twice a week, it’s now only happening once every couple of weeks or so. It varies and it doesn’t coincide with anything from an infrastructure standpoint.

I really like Wyze, but this stuff is so incredibly frustrating. If it can’t consistently work reliably, then I’m definitely going to have to go in another direction. I don’t really want to, not because I’ve invested so much in Wyze but because I in general like the hardware, app and features.

Wyze recently released some mesh routers that are semi-interesting. Unfortunately due to the significant investment I’ve already made in the Ubiquiti infrastructure here, I can’t seriously explore it.

1 Like

I can tell you now that I saw this on Reddit but power cycling the cameras every day seems to be holding. Basically bought a Kasa plug and have it setup to turn off for a couple minutes each day, so far it’s been working perfectly. I was made aware that this is a known issue with the wyze cams for about a year now and they’ve been attempting to fix via firmware but not successfully yet

1 Like

Oh nice! I had considered doing something similar with Wyze plugs, assuming they supported schedule-based power cycling, but I was worried they too would suffer from the same connectivity issue, and I wasn’t interested in seeking another smart home platform.
I think you’ve found a great workaround!