Wyze camera is corrupting and locking the SD cards

I have 4 Eye of different version all with SD cards. I’ve been using since 2017 and it is not until January 2024 that two of my four camera got corrupted card. I switched one camera with a new SD card still working but the second one just do not accept any new SD card. I start to think it is a way to get into they subscriptions…

1 Like

Same issue here! I purchased a Cam Floodlight V2 and pulled a WORKING micro SD card from another Wyze cam and immediately, it became “write protected”. I’ve tried using ‘diskpart’ to clear the readonly attributes without success. I’ve tried using chkdsk d: /r /f, format, and SD Card Formatter. All without success. I too am convinced Wyze Cam Floodlight V2 is to blame.

WYZE - What say you?

I have the same problem. I have several cameras and have been purchasing cards in pairs. Only the Pan V3 is locking the cards. No success unlocking it with different computers and Wyze cameras. The card was a new 128mb card with its mate running in an older V3 without problems. I had assumed it was a Pan V3 issue.

SD cards fail to read only mode, that’s by design to protect your data. As soon as an issue is detected, the internal controller locks it from further writes, usually permanently. If you are using standard SD cards with continuous recording, they will wear out pretty quickly. For continuous recording, you have to use endurance cards rated for constant writing.

It is possible for a faulty sd device to cause this by overvolting the card, writing incorrectly, etc, so it isn’t impossible that it is the camera’s fault, but it is more likely the card not being up to the task.

I’m using Samsung Pro Endurance cards in two Pan v3s and 5 OGs, so far no issues after about 8 months of continuous recording. The cards are warrantied for 5 years and their endurance rating along with the write speed of the cams (around 10MB per minute) says the 128GB version should last around 16 years (I’ll be happy to get the 5 years, considering they were only $12 each).


Add me to the list.
Wyze Cam OG SD card error
Firmware 1.0.80
32gb Kingston

Cam was running fine with this card since Nov 2023. Suddenly mid Feb '24 I get an error “SD card malfunction” Tried to format via cam… App gives another card error. I eject and the card will not mount on windows or Linux and is fully dead.

Figuring sometimes cards die, purchased a new sandisk extreme microsdxc 128gb (which support pages say is supported when formatted to exFAT). Also have been using the same cards in my 2 other wyze flood cams without issue.

Well I mounted and formatted the card in my computer first to make sure it was exFAT. Powered off cam. Installed card. And during power on recieved “SD card error” again in the app. Attempts to format via app fail. Eventually says no card detected.

Oddly, new card still mounts fine in Windows and appears error free.

Opening a support case. Will update.

Exactly the same issue, card is seen on computer but on cam it doesn’t recognize even after formatting with exFAT
Any update received from the ticket

Just had my second micro SD card corrupted by another Wyze flood light!!! WYZE FIX THIS!!!

I just had a Samsung Endurance card corrupted and unable to be formatted after about 5 months use. This was in a V3 cam.

I just had a microsd card fail to show up on my floodlight camera. I’m currently scanning it because windows 11 wanted to format it.

But just thinking about this before I look into this. I was wonder with this continuous writing, what happens if a file is corrupted and cannot be deleted when it’s time to be deleted in the continuous writing scheme.

Could it be like a tire stuck in the mud, ultimately damaging the card after several failed attempts at the same spot ?

Just a thought

The controller in the card should prevent anything from attempting to rewrite to damaged cells over and over, but that being said microSD cards are pretty sensitive and many of the cheaper ones don’t have the best controllers.

I have 3 OGs, and OG Tele, and 2 Pan v3s. 4 are running Samsung Pro Endurance with continuous recording for about 9 months now with no issues (once or twice one has said SD error but a reboot and it was right back to recording, and that was a really cold night). The other 3 are running these cheap generic 8g cards with motion recording only and they’ve held up just fine too.

So either it is just particular cameras with some firmware issue corrupting cards, or more likely the cards just hitting their endurance limits (or being defective). Any sort of moisture infiltration can kill a card too, either by shorting the terminals or getting into the memory itself.

joining this thread; suddenly ALL my Wyze cameras no longer have functioning SD cards. These have worked flawless, and the timing is too sus. I suspect a recent update corrupted my SD cards, which arent cheap btw. I am about ready to leave Wyze over this unless we get some kind of response… this is ridiculous.

Thanks for the input. Turns out I was able to reformat my MicroSD card on the computer. I was also able to image card and recover the mp4s but when I tried to figure out the last recorded mp4 and when the format got messed up. I ran into a problem of some of `the creation dates being wrong and also the time stamps on the video being wrong. So I decided not to spend anymore time on this.

Yes, this has happened to me on a number of times,
I have two different models of camera.
Both have had issues with SD cards stop working.

I have about 8 cameras in total and at lease 4 of them have had SD card issues.

The cards that have the most problems are Scandisk.

Different firmware, different cameras, different SD cards. Really strange.

Same for me, all of my 3 cameras microSD cards are no longer recognized. Seemed to happen about the same time, after months of no issues with the cards. I can’t format through app or with PC. Has anyone found a way to recover and re-format their cards?


No I opened a new thread here as well - All my SD cards are now corrupted / not able to be formatted - #9 by ssummerlin

This seems to be quite a widespread (and expensive, to the consumer) issue. Very displeased, not sure I want to continue throwing money at Wyze / cards if this is ongoing with no resolution. Cameras without the ability to record events are as good as junk unfortunately


After the Feb 2024 issue, one camera lost connection to the network and I could not get it rejoined and another camera only records to SD card 1 out of the 5 motion incidents I’m aware of (people coming and going). I’m surprised I get any incidents recorded. The playback function also seems to not work the same after installing recent updates. Using the scroll buttons sometimes it skips to a date in 1969! So, time to junk them and buy elsewhere. Bye Wyze!

Same here, two cards got destroyed, few days apart. Both Cam 3 cameras and Micro Center Premium 64GB * Class 10, A1, U3, V30 cards. Clearly there is something wrong with these cameras. I bought them because they were cheap but with all the problems they have, I don’t think they are worth $30. Since I already have them I’ll use them until they stop working but I won’t buy another wyze brand

Having an issue here too. Have 9 Wyze cams and 6 currently in continuous use for anywhere from 1 to however many years ago I bought into the short lived Wyze promise for features without a subscription. All cameras were recording recently but suddenly today 3 of the 6 cards are not working.

I never got around to opening a ticket yet… seems to only be impacting my OG most recent cam. The other two flood cams have cards and they continue fine.

As for “fixing”, I tried windows, mac, linux and couldn’t ‘re-format’ them.

Then on a whim I decided to put it in knock-off gopro cam… and when I powered it up… about 30seconds later the media was ready to use. I popped it into my PC… and it was now functional. Put it back in the OG cam, and it was recognized and recording.

But only for about a day or two… and then it went back to ‘sd card malfunction’ error… sigh

So if you have other devices that use micro-sd… try putting it in and see if it will format… you might get lucky.

Wyze cams still bricking cards. Any time (every time) I format a card via the wyze app, it bricks the card. I can see the video, but I cannot format it or delete the content. When I try, I get the “the disk is write protected”