Wyze camera is corrupting and locking the SD cards

Pulled the 2 SD cards I had in my cameras and have the same problem.

1 Like

Have other cameras started corrupting the SD card as well ? For me, it has been three out of six cameras.

I am beginning to think the same. Is this really a way to nudge customers to subscribe?

1 Like

I agree. On cameras that corrupts cards, new cards gets corrupted immediately after installation. And I have tried different brands of SD cards that work on other devices. Same issue.

Exactly. Now, I don’t exactly mean to say that Wyze purposely put such a problem into their product. What seems more likely to me, even though I don’t have proof, is that I could imagine (as an opinion) that Wyze is aware of such an issue while being in no rush to fix it. Now, on the flip side and what I was going to present in my video related to the following that could be contributing to the problem are:

  1. Working with high capacity micro sd cards (that may not be fully supported by Wyze). Afterall, I think Wyze advertises only 32GB support. Even if this is the case and we users are using an unsupported capacity, if the cards do work (which they do if we want to define ‘work’ as being able to write and read data at all), then there should be more research and information about the risk of using such high-capacity cards (in my case I’ve used 128GB and 256GB with success minus the locking issue).
  2. Using Fat32 - I had this issue from before exFat was supported. So, every encounter I had was with high capacity + Fat32. Is that contributing to the issue?
  3. Using “Continuous” recording mode. That is going to put a lot of strain on the micro sd cards (even though I’m in “SD” quality to get more days of 24 hour recording). Could that be a contributing factor to the read-only lock as relates to thoughtful response by @Seapup.

With all that said, this is what I was going to share in a video along with a description of changes from the original product, services, and marketing that originally included free cloud with 15 minutes (or so) gaps between detected cloud recordings, no ads in the app, and an offer to obtain person detection for a user specified contribution (which I did pay a one-time contribution but the person detection seemed to be removed and only available through cam+ subscription (please correct me if I’m wrong about this)). I can’t write all that I had experienced but I do note that many of the changes Wyze has introduced compared to a couple years ago seem to be to save money, potentially saving a company from a loss due to many customers (like me) that prefer to avoid a subscription-based system. This, in my mind, could be justification for not wanting to support high-capacity cards or not resolving an issue that may exist with such cards - but this is just speculation and my opinion that doesn’t need to be substantiated to be shared as an opinion.

Anyhow, overall, I’m appreciative of the product but was very frustrated with the number of cards that got locked on me and not sure I would have been worse off if I went to another system that had built in web server with s/ftp ability to upload.

A possible safety mechanism as a test: One suggestion would be to turn off micro sd card recording and eject the card (electronically and then physically) prior to any firmware upgrade (in case I’m right in there being a relationship between the lock and the upgrade - I cannot confirm now but that is what I recall as being somewhat linked to the card failure/lock). Then after the firmware upgrade, re-enable micro sd card recording (upon firmware update, the reboot should automount the micro sd card) - this the procedure I followed when I recently updated the firmware on a couple cams.

-Just my 2 cents.

1 Like

I don’t know. But for a camera that supports 256GB recording with very decent images in SD mode - that is quite a lot of data. For me, such a product doesn’t need a cloud solution since I can view the content anywhere over the internet right from the micro sd card (at least regarding content availability) using the app. Of course, their advance tracking that Wyze has been working diligently on are features that only come with the subscription - so if you are after that functionality, then the cloud makes sense. So, this was my concern about how eager Wyze may or may have not been to resolve this type of issue. But hey, hopefully I’m wrong. I need to monitor and document exactly what happens with my next batch of cards. But it’s hard to troubleshoot if I’m upgrading firmware and the mobile app (too many moving parts to nail anything down).

1 Like

I have the same issue with 6 of my cameras. 5 are pan v3 and one is cam v2. The cards will not format.

Same issue here, All my Wyze outdoor cameras and their base station bricked high-end endurance microSD cards. Cameras are more than 2 years old and out of warranty. And on top of that Wyze pushes for subscription. All that combined really pisses me off.
One thing I noticed - the cards are rather hot when taken out of base station which always stays inside the air conditioned room. It might be that Wyze heats up microSD cards to the point they get fried.
On the other hand, my cheap dashcam stays on in a summer heat and there is no problem with microSD card in it. So Wyze is definitely responsible for this issue, even if partially.

Interesting that your dash cam (neither my action cam’s) has not locked the sd card the way the Wyze security cam’s seem to be doing.

May I ask if you are recording continuously or only events? I’ve changed my configuration to only record events in case the 24/7 recording may be a cause or contributing factor to the problem.

I checked the last timestamp of the successful write to two of the bad cards that I kept, and yep - they both failed within 24 hours of each other. That’s pretty coincidental to me.

I’ve had similar problems with my V2 cam. I’ve used micro center and pny. My cam doesn’t even record constantly and I’ve went through 3 or more cards. Some won’t reformat, others aren’t even recognized. I’m also believing it happens after firmware updates.

Nobody is listing SD card specifics; that’s crucial. I’ve had PNY & Micro Center cards fail a few times. I’ve replaced them with 256 GB cards directly from Wyze, and have years of flawless operation so far. I’ve also used high end Samsung SD cards for high speed 4k continual video recording and they also have lasted several years so far without issue. The correct cards are going to cost you more, but they don’t fail as cheaper cards tend to. This is an easy issue to remedy.

I have used so many SD cards, from cheap to high end. It seem to me that this problem happens after an updates. This last update 2 out of the 3 cameras with sd cards failed, both in my Cam Pan, one card I got to work by taking card out rebooting sticking card in and doing another reboot, the other I could not get to work, even deleted cam and started all over, and still will not work. Bring the sd card in to read on pc and it will not even recognize it, can’t do nothing with it. I’ve had this cam since 2020 and have bought 6 sd cards for it, sets under my covered patio in the shade, it’s 26 degrees today.

That has been my experience too, with multiple cards failing in the same general timeframe. What I do now is, “Eject” the card via software and then physically. Then I’ll perform the firmware update (a bit hesitantly) and reinsert the cards after the reboot.

Having been a Wyze customer almost at inception of Wyze, my experience on all their Generation of cams has been the same. I’ve gone through sooo many brands of high quality mini SD. intermittent issues on local recording all the time. I know have two key cameras on full subscription as I can’t have them miss key recordings! So I believe your theory

1 Like

Same issue here on 2 V3 cams using Samsung Evo Select 32gb cards :frowning:

I have two of five Cam Pan v3 that routinely eat SD cards… both Samsung and SanDisk. I won’t use PNY’s. The brand doesn’t seem make a difference in my case.

I just had a Cam V3 just eat it’s 32GB Sandisk Ultra so yeah, seems to be a major issue, and expensive. I’m glad I didn’t have a bigger card in it.

I have the same issue. My sd card is locked in read only state. I’ve tried everything I know to delete the two folders locking things up. I believe it is a Wyze camera issue and hope they look into it and find a way to resolve it. I love my wyze cameras and hope this is just a tempoary situation.

Same issue with a rarely used Lexar 32GB card in a new Wyze OG cam (a month old) with events recording only. Unable to format it with Wyze cams, computer, cell phones, and cameras.

Maybe it is just me but all the new updates and Pushing for everyone to do on line subscription my on board SD cards have been almost useless. I think it is time to find New cameras as Wyze had become so un reliable they are almost useless for anything other than a baby monitor.