Wyze Cam v3 cam plus issue

Hi when i go to an event to watch it, I get a pop saying " Event Videos are available for cam plus devices. To use this feature, please go to our Sevices page and assisgn a serivce such as cam plus to this camera"

I have an active subscription and it is assigned.

any ideas?


1 Like

If all your cams are assigned to CamPlus already, there seems to be a disconnect of updated data between the cam, the app, and the server. You might need to force a realignment of the three.

  1. Unassign the affected cam from Cam Plus in the Services menu.
  2. Clear the Cache in Account Settings
  3. Sign Out of the App in Account
  4. Close the App
  5. Long press the app icon, select App Info
  6. Force Close the App
  7. Restart the phone
  8. Full power cycle the cam (unplug)
  9. Wait for the cam and phone to fully reboot
  10. Log in, assign CamPlus to the cam and test.

Hmm, I started to follow your advice hoping it might address my V3 Alexa announcements issue, but I just found I can’t remove the new V3 (or anything else) from CamPlusLite.

That’s correct. To remove it from Lite you need to be able to assign it to CamPlus. The only other way is to cancel Lite and re-subscribe. Really stupid.

1 Like

Hi, thanks for suggestion. I’ve tried it and still no good?

Thanks @WildBill . This wouldn’t bother me so much except that I also just realized it’s not logging person events at all, either. Any ideas?

What app version are you currently running? Have you verified that that cam is being listed in the Services page assigned to the CP license?

Looks like 2.37.1(134) for the app version, and yes, I added the camera to Lite from the Account, Services section of the app. Carver suggested a firmware upgrade…

I think we have two different discussions going here for two unrelated topics. Either that or I am really confused.

@Beanbuff created the topic with a problem of the App not recognizing that a cam is assigned to CamPlus and returning CamPlus pop-up advertisements for uploaded events.

@Customer’s posts and @WildBill’s replies are dealing with the lack of Alexa Person announcements for cams assigned to CamPlus Lite which aren’t uploading Person Events.

Thinking we need to have this thread split to avoid further confusion.

Referring to the @Mods for assistance.


Sorry, I already asked and am discussing in an older thread at

MOD NOTE: Yes, topics are a bit intertwined. Rather than split this thread, I’ll just ask that future comments regarding Alexa person announcements be made in the thread referenced by @Customer above. That should keep things organized.


I am having the same issue, tried everything i can think of, did a chat session, they just said send a log file and wait for a firmware update, anybody have a fix for this? paying for cam plus and it dont work???

1 Like

Also, if the video will play it says it 20 seconds but will only play 2 seconds of the 20 second video.

I’m not sure why, but the app and the server aren’t on the same page.

Some questions…

  1. Did you attempt the steps above:point_up: to try and resync the app and cam to the server? When you test, only test on new videos created. The old ones may not work.

  2. What app version and firmware version are you using?

  3. Can you please post a screenshot of your CamPlus Services page.

  4. In the Live Stream of the cam, is the CamPlus logo in the upper right purple?

  5. We’re these cams recently on a Trial or were they recently just assigned to a newly paid subscription? Were they on an existing paid subscription and changed or did they just start this out of the blue? What prompted them to start doing this?

As for the 2s of play time… I suspect there has been a video upload error and there is no video to play. The green question mark is what indicates this as this won’t appear unless there was an error.

Wondering if you can help with this issue… Are you running Android and also viewing via mobile/cellular, limited bandwidth WiFi or non-US based connection?

1 Like

1 Like

App and cameras are the latest firmware,
Was a trial subscription turned to paid, cancelled all subscriptions and reordered
Android phone app, good connection

1 Like

US connection
Good bandwidth

1 Like

Thx for the updated screenshots and info. This is currently being looked into to see if it can be reproduced and a source identified. What app version number?

1 Like

In your screenshot from yesterday with erroneous popup, you are not using WiFi. You are using mobile/cellular connection. Now that you are on WiFi, can you try to access this same Event video?