Wyze Cam v2, Wyze Cam Pan, Wyze Robot Vacuum Firmware Beta Test 5/12/2021

When I go to the Wyze portal and login I do not see this option. Can you provide more detail please on how the URL please?


You need to enroll on your wyze app. Here are some helpful instructions.


LOL So simple. Sorry about that. Using the Android beta app I have now added the Robot Vacuum and waiting for the firmware update to show up. So far nothing. I’m on 1.6.113. I’ll check in a few more minutes.

1 Like

Also, the Wyze Beta app on my Android device is v2.21.12.

1 Like

Still no beta firmware upgrade available. I do have the Robot Vacuum added.

Hmm… That’s odd. The latest beta FW I have is 1.6.30 for the vacuum. I’m not sure how long it takes to update. I thought it was instant. I’m also on Android beta 2.21.12.

I have a support case open on the whole thing.

I’ve been sent over to centercode by support. I submitted a support request there also. I’ll just leave this alone and see if something changes.

It’s not a centercode issue though. You don’t have to be signed up for centercode to update to beta FW. Centercode is for testing beta hardware. I’m not sure why the update has not shown up for you. Do you have a screenshot that shows the vacuum is enrolled in the beta app? Do you happen to have your wyze support ticket?

1 Like

Well, I’m confused, lol. This is a thread about new Beta firmware (1.6.126) being released almost a month ago as I post this. Yet I can only see version 1.6.113 as @jjwatmyself says. 1.6.113 is a released version, so that means no Beta version is available at all ATM. Wyze does have the ability to throttle how many people can download an update, but after a month I would expect it to be readily accessible.

There are 5 posts by @WyzeHongfei in this thread, but I don’t see one that says they are throttling or have pulled the update. But maybe they will reply as to why we can’t see the update (yes, I have the robot vacuum selected for Beta firmware updates, see below).

@cheaplikeafox is the 1.6.30 version you say you have a typo? That would be pretty old, if a version with that version number was even ever released.


I just updated to 1.6.130


Interesting. Yes, I see another thread where 1.6.126 was replaced by 1.6.130 three weeks ago. That means @cheaplikeafox’s version is probably .130, not .30.

Unfortunately, I can’t see that version either.

We probably need to move to that thread and abandon this one.

1 Like

I have version 1.6.130 as well. My Vacuum has been running like a champ since.

I have read in other forum threads that there may be a little glitch with the Beta Program Page. At times, you need to go into that page, deselect all of the devices on the page you opted to do a FW test for, then save the page. Then go back in and select the devices again. This seems to trigger a refresh of the FW and you may get new FW updates. I tested this process and actually presented with 2 devices which needed FW updates which never presented itself before.

Wanted to pass this on as something individuals could try to see if Vacuum FW is available.


Sorry it was a typo. I have FW 1.6.130. I moved it to the latest thread about this FW. Thanks. Not sure why you can’t see this FW update either though…

I already tried going to the actual device and then device info and FW, but I just tried both your suggestions again on both the current iOS production app 2.20.142 and Beta app 2.21.26. Still no go.

Feels like they took it down?

Thanks for the suggestions though! :slight_smile:

1 Like

Wonder why they took it down, if that is actually what happened. Mine has been working fine and I have not experienced the issues I have had before.

1 Like

One possibility is they may be about to release a new version. Another is I may need to upgrade to an interim version first.

1 Like

Good idea and have tried deselect and reselecting. Response to the ticket I have was to logout and login on the app, which from what I can tell , Wyze for Android is done by doing a clear cache and clear data on the Android app. I also tested selecting all devices for beta in beta enrollment. The v3 cams and WYze plugs do not show a newer (beta) level firmware either. Which might be because there isn’t a beta for those at the present time, but might also be the same issue.

@Newshound you need to charge your cell phone my friend. :smiley: but also @John.reiland just updated to 1.6.130.

@John.reiland was Rosey the Robot already signed up on beta (i.e. got a beta spot long ago and didn’t update until yesterday) or did you just sign-up for robot vacuum beta?

Android beta versions tested 2.21.14 and v.2.21.12

Until this issue is resolved, I’ll be on my hands and knees doing Henry’s job (my robot’s name). Or the dust will be uncontrollably gathering.

Just as an FYI:

My Devices are at this Version vs Released Version. Figured I would provide for comparison purposes. Bolded are beta Version. I did not provide versions for all of my devices, nust the ones which may be pertinent here.

Android App Beta Version: 2.21.14 Production - 2.20.21
iOS App Beta Version 2.21.26 (2) Production - 2.20.142

  • V2 Cam: Production -
  • V3 Cam: Production -
  • Plug (Key Design): Production -
  • Plug (No Key): Production -
  • Outdoor Plug: Production -
  • Robot Vac: 1.6.130 Production - 1.6.113
1 Like

I’m in the same boat as @jjwatmyself and @Newshound. I’ve gone through all of beta app rigamarole (version 2.21.26), but still only see firmware version 1.6.113, which is listed as “Up to Date”.