Wyze Cam v2, Wyze Cam Pan, Wyze Buds Pro, Wyze Headphones Beta Firmware Test 10/25/2021

Wyze Cam v2 & Wyze Cam Pan:

Firmware Versions:

  • Wyze Cam v2:

  • Wyze Cam Pan:

What’s New:

  • Reduced the amount of time Cam Plus records video after motion is done

  • Bug fixes

Test Emphasis:

  • Overall camera performance and stability

  • Firmware update experience

Wyze Buds Pro:



What’s New:

  • Add a Noise Cancellation Off option for touch control

  • Improved battery measurement accuracy

  • Improved an issue that caused occasional reboots on certain phone models

  • Fixed a bug that caused the right earbud to turn noise cancellation off

Wyze Headphones:

Firmware version:

  • 2.1.143

What’s New:

  • Improved auto-pause

  • Fixed a bug that prevented muting in Zoom meetings on Windows devices

  • Fixed the LED light status when the battery depletes

  • Fixed a bug that caused failure to power on in some cases

  • Earbuds Pro updated without issue
  • Headphones updated without issue
  • v2 Camera failed first attempt to upgrade. Trying again


No Luck on Attempt 2. Here is what I got, but the Camera still works:

Decided to clear cache, force stop app and clear local cache as well. Then I power cycled the camera. Trying to update again.


Excellent, didn’t know there was a tap and hold to toggle ANC and Transparency Mode :slight_smile:

1 Like

I only have two V2 cameras that don’t have RTSP firmware, but they both updated just fine the first try.

I think you got those two backwards. The V2s updated to and normally the Pan has one higher number in the second position…


Just got my v2 Flashed to the latest Beta Firmware. Has to manually flash it back to the Production Version in order for the update to succeed.

Initial tests on the v2 seems to have corrected the AI notification issue with the other Beta releases. I will do more testing to be sure.

But so far so good, way to go Wyze. :slight_smile:

@WyzeBaohua , thanks for your help on this

1 Like

Updated 8v2s and 3 PansV1. Some cams needed 2 attempts but finally updated. No issues so far.

1 Like

1 v2 and 1 Pan updated on the first try. 4 Pans repeatedly failed to update until they were first power-cycled. AI detection is finally working again (so far) after being broken from the .352 beta. :grinning:

1 Like

5 v2’s updated with out issue using the bulk update method

Wyze Buds Pro Updated perfectly
+Noise Cancellation worked through the touch controls, great add thank you

  • @Yichen One area to call out, the touch control to trigger the Alexa Voice Assistant still does not work on iOS (now 15.0.2) When you trigger the Alexa Voice Assistant you get the response “Open the Alexa App and Try again.” this has been an item since Wyze Beta 2.24+ more information here

Wyze Headphones updated without issue as well


This seems to be a down grade :frowning:


corrupted my V2, and now shows just a solid orange light on reboot and won’t connect…great

do a manual flash to the last production version. Then do the update and see. I had to do mine that way.

I was testing many other FW versions for the v2 and it was in a state which would not do the update.

1 Like

V2 Cam updated first try for me. So far so good. Will report back if I notice anything.


Updated v2 cams, Buds Pro and Headphones yesterday. All updates went smoothly… no problems to report since updating.

Update: Sync Time fails under Advanced Settings (again).
v2 cam beta firmware
Log ID: 335365



ok did that, it works…but now it says I can’t record to SD card, no SD card detected lol

try removing the SD Card, then power cycle the camera. Then go to the app and make sure you can syill connect to it. If you can, put the SD Card back in and see if it is recognxed.

you may need to format the sd card outside of the camera.

It says my Cam V2 is Up to Date at version so no update happens.

Have you tried Power Cycling the Camera by Removing power for a few seconds and then adding it back in?

Also, since these Beta FW to test you should check to see if you selected the v2 for Beta FW. To do this start the app, go to Account Menu (Bottom Right), Scroll to the Bottom and select Beta Program, Click Edit (Top Right), and finally select the devices you wish to test the Beta FW for. Make sure you select the v2 as one of them to receive the FW. Also, make sure you select Save after you finish your selections.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.