Wyze Cam Outdoor Firmware Upgrade Fails

Still seeing the same issue. I’ve not heard back regarding the logs that I provided.

22 days since my last response and this issue is still ongoing.

I’ve been having the exact same issue since trying to upgrade from a month or so ago.
I have followed all recommended steps: reboot, keep within 6 feet of base station, remove sd card, make sure base station is up to date, plugged into power/unplugged from power, deleted from account and reset up from scratch etc. Always fails. Not seeing a way to flash the firmware via sd card either so I haven’t tried that. Other things I’ve tried: Using a different phone. Made sure I was on the exact same wifi network (2.4), rebooted base station all sorts of stuff and the 8 or 9 minute timeout for the fail is excruciating. If anyone has a suggestion for something I’ve missed?

If you’re in the beta for the Wyze app, they recently released an update to that to try and fix this. Seems to have worked for some, but not for me.

I am having the same issue with my two outdoor cameras

Just another update on this. After manually flashing the firmware as stated here, I have still not been able to update the Wyze Cam Outdoor firmware via the app.

Same Problems here, following!

Unfortunately no progress has been made on this for me. I’m running the most recent beta version of the app and am still unable to update my Wyze C Outdoor firmware through the app.

I’m really glad to see that I am not the only one with this problem!
Like everyone else, I can update the base station but not the Outdoor Cam.
I did contact support awhile back, right after my pre-ordered cam showed up.
They replaced the camera, still had the problem,then they gave me the file and I flashed it manually…it’s been fine until a week or so ago when I got a notification that an update was available…yeah, it failed again!
If I can locate the new firmware file, I’ll flash it manually again I guess.

This is the conclusion I am coming to as well. I’ll just continue to flash manually when a new version is available for it. Beyond that, I am unlikely to buy another Cam Outdoor even though I have some good use cases for them.

I know where the files are. How do you flash the Wyze Outdoor Cam?

I would like to know where the files are and what flash program to use as well. OBTW foes anyone from Wyze look at this forum??

Honestly doesn’t seem like it most of the time. :laughing:

A microSD card is required for flashing firmware. These steps assume that you are starting with the microSD card inserted into the computer used for step 1.

  1. Download the firmware zip file from the Release Notes & Firmware page.
  2. Unzip that file to a known location. Then copy the sd_update folder to the root of a microSD card.
  3. Turn off the Wyze Cam Outdoor and insert the SD card into the camera and turn the camera on. The light on the back should go orange → blue → purple and stay purple for a bit before going back to blue.
  4. Turn off the Wyze Cam Outdoor and take out the SD card, re-insert to the computer and remove the sd_update folder.
  5. Turn on the Wyze Cam Outdoor and your firmware version should be updated to what was downloaded in step 1.

I have just used these steps to update to version I am also using the beta version of the Wyze app to gain access to beta firmware versions, and am still unable to update the Wyze Cam Outdoor to the latest beta version of the firmware through the Wyze app.


Thanks! Took several tries, but finally got it updated!

A great big thank you for this and your prompt answer. As far as I am concerned, you added about 70% of the value of Wyze’s customer help. This should be on the Release Notes & Firmware page also, if Wyze is not to be busy to really help.

I noticed that while I can use a 64GB or 128GB microSD card on V2 and V3 cams, that ONLY 32GB microSD cards work on the Wyze Cam Outdoor for me.

But your instructions worked perfectly the first time with a 32GB carde.

Again, Thanks!

Glad I could help!

This is so annoying. First I buy an expensive hub because it says right on the box that it is compatible with google home…it is not. They have been trying to fix that issue for over a year. I have had a million problems in between that, and now the new firmware update has bricked my outdoor camera and base station. I will be [Mod Edit] if I am going to spend even more money and time (I must have 50 hours invested in doing their tech work) and go out and buy another SD card to fix their [Mod Edit] .
One time fee to any other company and they will come to my home and fix any issues (if there was ever one)

MOD NOTE: Post edited to conform to the Community Guidelines.

What isn’t working with Google home? I don’t have a hub, but my outdoor cameras are recognized in Google home.

Firmware update for wyze outdoor cam WVOD1 not working auto via App or manually with 64GB micro SD. Cam is working with charge at 100%. Version is trying to get Base WVODB1 firmware has address , while cam shows Is that a problem?

You are not the only one. First they bricked my Cam Pans with that last update (they had to send replacements. ) Now my WCO’s will not reconnect since the last firmware updates. About to abandon the whole ecosystem, because each new update seems to break something.