Wyze Cam Outdoor - Battery life - Troubleshoot with WYZE

@blhinman , I’ve heard from multiple people that they get little response to online tickets, but if you call them their support and service is very good. If you have not called them, you may want to try that.

1 Like

WCO updated to new firmware recently (couple days ago) and now I see battery issues. Battery was 91% yesterday and dropped to 75% this morning. Within a span of few hours it has again dropped to 71%. Should I be worried? Is there a way to get logs off the device to see battery drain over time?

I found many of my battery issues were related to me trying to run base stations on WiFi. I plugged both my bases back in to Ethernet, and my batteries are around the 25% drain per month level. Maybe this helps at least a few people.


Is there going to be a solar panel option for the outdoor cams? Colder climates seem to drain or damage batteries, so wanting to see if this would be an option. Thank you


This 3rd party option works. I have 4 of them with 4 more on order

Hi @jinxu1776 Welcome to the Communit Forum! :slightly_smiling_face:
You might want to vote for it on the #WishList (Wyze Solar Panel - Solar power adapter)
Check out this post (Solar Panel to charge outdoor camera)


I doubt it because they do not want you to leave them plugged in all the time. I guess technically though that would only be plugged in 12 hours on and 12 hours not with the movement of the sun.

I wonder if people leaving them plugged in is causing some of the battery issues?

I have just started to get some of these but they are taking awhile to come in. Glad to know I am on the right track.

My WCO goes from 98% to 0 in less than 1 day. Do I have a defective WCO?

Sounds like it–that’s what mine did. Wyze replaced it.

If you are on the WiFi connection only now try and go back to the ethernet connection and see if that helps. That made a huge difference for me.

1 Like

I moved my basestation closer and that helped for WiFi only

1 Like

This is what I did and it solved the battery drain issue. The cameras I have are now lasting much, much longer just like they did before I disconnected the LAN wire. With the bas station connected by cable to the router, instead of using WiFi, the issue has been resolved for me.

1 Like

updated to firmware several weeks ago on my wco and now battery life is very poor. Charged less than 2 weeks ago and now down to 31% Only recording 1-2 events per day and only 12 to 17 seconds per event. I tried to roll back the firmware but it says that there is no other firmware available to roll back to now. What’s going on? I’m becoming a little disenchanted with my little investment.

Try going back to the Ethernet connection only and see what happens.

Thanks, I’ll give it a try. But I’m still confused as to why they have taken away the ability to roll back to an older version of the firmware to try to solve a problem that you didn’t have before the upgrade to the new version. Any ideas? Thanks.

I’m not sure either but hopefully someone will see your post and provide some feedback.

I have been using 2 WCOs with the latest firmware with WIFI connection. Both of them have been draining only around 1-3% per day. Two nights ago one of them finally drained down to 18% at which time I decided to charge the battery. Within 2 days, it went from 100% fully charged to only 27% without changes to the settings or unusually higher number of events than previous days. Basically I turned it off, charged it, and turned it back on. It is in the charger now again, but there is no reason for this to drain that quickly.

Today, customer service had me click on the Moon icon (for the night vision mode) in the setting when trying to diagnose scheduled motion-only recordings having green tinted images on the 2nd WCO. This is an unrelated issue, but since toggling through all options once on the Moon icon, the battery on this 2nd WCO went from 81% now down to 53% within 5 hours. Nothing else has changed and no events recorded since this morning.

Either the app is reporting the battery percentage incorrectly, or I suspect something is seriously wrong here. I hope Wyze engineers are monitoring this forum and taking notices of these problems.

I had a similar problem with my wco and another forum member suggested that I disconnect from the wifi on the base unit and only use ethernet cable. That seemed to work f for now.

@gooday - Did you move the base station closer to the cameras or closer to your router?

BTW, I have two WCOs which have been running for a little more than a month and are currently at 61% and 67% battery charge. So, hopefully they will run for nearly the 3-month indicated timeframe.