Wyze Cam 3 not connecting my network


Just trying to setup my new Wyze Cam 3 and am having difficulties: I can get all the way thru the process until I get to the part where I scan the QRCode on my phone. It does scan it but I get a message back about 10 seconds later that it was unable to connect to my network.

-I’m on Centurylink here and using an iPhone.
-I’ve unplugged my router/modem several times.
-Uninstalled/installed the Wyze app,
-Tried the “forget this network trick” on my iPhone.
-Started the entire installation/connect process with the cam & iPhone multiple times.
-Made sure I’m connecting to MY Network (its not 5g) and using the correct password.

My god this frustrating- it shouldn’t be this difficult. Any tips or tricks or advice is appreciated. Thank you!

Welcome to the forums! Do you have any special characters in your password? Spaces at the begining or end? Here is a page of connection troubleshooting items. Can you check these out and see if any help you get connected?

1 Like

No spaces in my password but I do have something like this in my network though: Smith_House_Modem.

Thank you

1 Like

The underscore isn’t specifically listed on that page as a special character, but the wording makes me believe that’s an abbreviated list. Checked ng the forums, it looks like the underscore has been a problem in the past, haven’t seen it effect the v3 yet. Might be good to test by removing the underscore from the ssid and try connecting the cam.

1 Like

Thanks. I guess I’ll have to try that eventually but damn, changing my Modem name will probably mean I’ll have to reconfigure about 15 different devices to the new name if that makes sense. Geez what a pain.

1 Like

Do you have the ability to make a guest network? That way you could keep everything else the way it is. Maybe not the best idea but something to try.

Great idea actually, Thank you but I don’t think that’s possible with my setup (but I will look into it more).

1 Like

Alrighty! I hope the issue is as easy at that, and that you can find an easy fix. Keep us updated with how it goes! :slight_smile:

Wasn’t able to setup a Guest account on my Modem/Router.

Thank you though!

I doubt it’s the underscore.

It is probably either the need to to temporarily turn off mobile data on the phone, or that pesky new “private address” network blocking feature in iOS.

1 Like

Hmmm…I’m a little confused why a setting on my iPhone would affect the Cam3 from connecting to my network? What am I missing? Thanks!

Because at that point you are NOT connecting to your network. You are connecting to your camera’s own network and trying to convince it to join your home network. If your phone sees an easier path to the Internet (your 3G mobile data) itsy stop trying to use the camera’s temporary network. Happens all the time.

The “private network” feature (which is fairly stupid) is similar in that it blocks Internet-free networks.

1 Like

Got it. I appreciate the explanation. :slight_smile:


Im just setting mine up and was having the same issue. I took it in the house and sat it right next to my router and it connected right up. I’m finding this thing can not get more than 15 feet from the router and it looses connection. All my other Wyze cams are hundreds of feet from this same router so obviously I have a dud of a unit. Just not sure yet if this is common to all these new cams. Time will tell.

Yes I brought 3 packages ,plus 3 additional outdoor cameras.
So am i screwed, also pre- paid for full yr .24/7 monitoring package upfront, hope that will work when I get that ‘home kit”.
I tried everything like everyone else-still nothing