Wyze bulbs are not responding to rules

Possible but lengthy solution. I’ve been watching the logs of the scheduled events and what I was seeing mostly, not always, was that things like bulb temp or brightness was going off before the actual light was turned on. In my opinion this is a software issue that needs to be addressed by prioritizing commands. I.e. on first, then brightness, then temperature or color. I’ve experimented with setting a schedule as follows

Original schedule:
Carport on 530pm, brightness 100%, temp 4500k
Carport change over 930pm brightness 1% temp 2700k
Carport off 7am.

New schedule
Carport on 529pm
Carport brightness 100% 530pm
Carport temp 4500k 531pm

Carport change turn on 929pm
Carport change brightness 1% 930pm
Carport change temp 2700k 931pm

Carport off 7am

This time consuming [Mod Edit] scheduling seems to work. Literally a different rule for every operation 1 minute apart so these [Mod Edit] bulbs don’t get confused and changing brightness before the bulb is even on… This light went from never being right to 2 days of perfect. I have added another bulb with this same scheduling to try it again. This bulb consistently didn’t even turn on at all so we’ll see. Fingers crossed. Ok the second light worked flawlessly last night following these same lengthy rules.

MOD NOTE: Post edited to conform to the Community Guidelines.