Wyze Band with Alexa and SmartThings

I have a new Band (today), and so far I like it. It’s pretty much what I expected. A a few issues with Bluetooth connectivity, but I worked thru it pretty quickly. Mostly, I was in too much of a hurry to play with the new gadget.

I have had a Samsung SmartThings for about 3 years and it is fully integrated with Alexa. The good news is that the Band/Alexa interface works well, BUT seems to have one issue. For example, when I use the Band/Alexa interface to turn on my “den light” that is interfaced thru SmartThings it WORKS…but I get a message back on my watch…”Sorry, I don’t understand, please try again.”

Again, it worked…turned on the den lamp, but I get the above message. Pretty much everything I’ve tried…turning on switches, virtual and real works great, I just get the above error message back on my Band.

Is anyone else seeing this, and who/how do I go about letting Wyze know this. It’s not really that big of a deal, and with the new release I’m guessing they have ”bigger fish to fry” than this.


I’m getting same message when action successfully completes.

I’m getting the same message but no lights turn on.

I get the same thing, but I am using Hubitat for my HA.

I receive same issue. Figured it is a bug that will be worked out.

I am getting the same thing with the Vesync and Harmony smart devices I use. The command is working but I get an “I don’t understand” message.

Will there be a Military time option.