Wyze App forces password reset every login

Just got some Wyze plugs and installed the Wyze app v2.6.42 (which is current as of this posting). If I log out of the app or install the app on another device, when I log in again it always denies the login and tells me the email or password is incorrect. The only way I can log in is to go through a password reset (and I just set it to the same password). I am using the correct password, and even used it to log into this site, so it has to be the app.
So far I’ve tried a force stop on the app and restarting, restarting the phone entirely, and uninstalling and reinstalling the app. Still no love. Since it always initially denies my login, I cannot add this to my Google Home group.
For the record I have a Pixel 4 XL, Android version 10, security patch from November 5.
However, the same thing happens with my wife’s iPhone running the latest iOS version.

That is odd. Try writing both the email and password in a text document on the phone and then copy and paste from that to the Wyze App login screen. This eliminates a typo.

Done it; not a typo. It’s doing it from every device with the app but I wouldn’t think there would be anything network related. No other apps have that issue.

I am running iOS 13.2.3 myself. As is my wife. Between us we each have an iPhone X and a 6th and 7th generation iPad. Neither of us have even heard of something like your describing to be honest. The app works just fine on all 4 devices as well as an Android tablet I have.

That said, I think you need to involve Wyze support. We are all users just like you, their support team has tools we don’t.

Open a support ticket here.

Why do you have to log out of the app? I never even realized one can until I read your post. Until they fix the bug (if it’s really a bug), just don’t log out.


I don’t necessarily log out of the app. But I do install the app on multiple devices (my phone, my wife’s phone, etc.). Then I have to use the login to add it to the Google home app. When the account locks or password resets, I have to login again on all devices.
I didn’t respond yesterday because I was unable to log in to the forums through a PC, and my account was eventually locked again. The Wyze support team unlocked the account for me and so far everything is working. Hopefully the issue is solved, I’ll wait and see.

1 Like

I’ve installed the Wyze app on several devices both Android and iOS and never experienced that.

But then I’ve never used Google home app. I try to minimize contact with Google :grin:

Hopefully you figure out what is causing your account to be locked. You don’t by chance have young kids that like to play with your phone or tablet?

This is exactly same thing happened to me. Once I reset the password it works good. And certain time later, usually next day password is invalid and won’t login. So I have to reset password again. It still repeats everyday sooooo annoying.