Won't Proceed Past "Home Name" - Home Monitoring Setup

Wondering if anyone has encountered this issue:

I am unable to get past the Home Monitoring Wizard setup “home name”.

Hub Setup ✓
Keypad Setup ✓
Sensor Setup ✓

→ Home Setup
→ Address Entered ✓ (Tried Auto-complete and Manual)
→ Home Name “name your home”
It doesn’t matter what I put it. Even tried clicking their Suggestions.
When I click “Finish”, it loads, then does nothing.
I have no option but to go back, or cancel the setup.

Just getting frustrated because I bought the hub+subscription in April (they started charging for the subscription immediately, without even receiving the items yet), got to set it up last week.

The hub had the issue. It also had other HW issues so I went back and forth for days to get it replaced. I have tried setting up my brand new hub, and still the same. _Won’t get past the “name”.

Tried on stock firmware, and updated firmware.

Google Pixel 2 XL.

1 Like
1 Like

Thanks. will respond to your thread.

1 Like