WOC stopped creating events after upgrading firmware

I have 3 WOC’s and all were recording video events with no issues. I upgraded firmware,, on one of them and now it does not record events.
The 2 other are still running firmware and still record events with no issues.

I tried power cycling the WOC, but that did not help.
I tried the tips in the video and that did not help.
I am hesitant to downgrade the firmware back to, as historically that has failed epically.

Is there some hidden setting/button pushing that needs to be done to reenable event recording?

Thanks in advance.

I have 4 cams with all working.Are you using IOS or Android. I am using iPhone and iPad. Is the record events button turned on?

I use iPhone. Detect motion and Notification both on.

I powered cycled the base station and WOC a couple times and turned on motion tagging. Once done, it now records events.

I am guessing it just had a hiccup, not sure. Will watch it a bit before upgrading my other camera just to make sure.