Video Doorbell Pro connects to Wifi but no cellular access

So I just installed a video doorbell pro on my network (2.4GHz) - I have a bunch of other Wyze cameras and devices on this network.

Doorbell connects fine, and I can access it on the Wyze app on my iPhone, but ONLY if I’m on Wifi on the phone (or iPad). All other cameras / devices are accessible from anywhere when I’m on cellular only, but I can’t access the VDP - I just get the constant “Connecting Step 1 of 3” and it never establishes connection. Back on my Wifi connection with the phone/iPad and all works fine.

Any thoughts?

1 Like

I also am having the exact same issue. I thought I connected the doorbell somehow to my phone<s hotspot or something!!LOL…But Away from home I get the same and hope for some help here as well. At home on my wifi, everything is perfect. Just away on the cellular, the doorbell is the only thing that does not connect.


So far no traction on this. Have upgraded firmware, removed and re-added the VDP, same: works fine when iOS device is on Wifi, but VDP is inaccessible from cellular - all other devices (multiple cameras, plugs, lights, thermostats) all work without issue in Wyze app, only VDP is a problem.

I contacted support - they got back to me a day later with a cut and paste of the Video Doorbell Pro’s setup guide - didn’t even read the text of the support request as far as I can tell.

If anyone has some insight I’d love to hear about it - I’ll post here if support ever helps me.

1 Like

Thanks for that! At least I know someone hears me and knows my pain….


I too am having the same problem and so is my co worker that just got hers and set it up last night. This is ridiculous and extremely misleading to advertise “view from anywhere” clearly that is not the case. I have reached out several times, submitted logs. No one has helped at all. In my opinion they obviously know what is going on so why have they not addressed it anywhere? I don’t see it listed anywhere on their website for troubleshooting or anything. They probably shouldn’t advertise viewing the camera from anywhere when that is a lie. What is the point? Lol

OK, so I’m not the only one - good to know. Curious what cellular network you all are on? Verizon here.

So reply number three came in from Tech Support just now; no real help yet (and unfortunately still not reading the text of my replies carefully), but I’ve submitted a device log and we’ll see where it goes - I’ll post when I hear something.

Might help to have your coworker post here (just to build the thread), and also file support requests.

1 Like

Thanks for your update. I also have sent in my diag info and asked for help but here has been the only support I have found. I am ready to trash it.


We run off Verizon and have IPhones.

OK, unfortunately it appears that this is a known issue - here’s the latest from Wyze support:

Our engineers are already aware of this issue and are currently working on a fix.

While we don’t have an update yet, we hope to see this resolved in an upcoming update and we have no ETA yet of the time frame…

Sadly, I don’t have any further suggestions to offer at this time.

So - bummer - seems like we are SOL. The options are to wait for…no one knows, or just return the unit and move on. Oh well…

Update from my co worker: her camera is now working on cellular data. She does NOT have Verizon. Could it be something with Verizon? A Firewall or some kind of block. I sure hope they get this fixed before we go on vacation and have no WiFi!!

Certainly possible, but who knows? I do know that Verizon worked just fine with my Ring doorbell - guess I should’ve just gotten another Ring. I’d be curious what cellular provider @bubba2651 is using?

Hey everybody!
My camera worked for 5 minutes when I was out at the market the other night then suddenly went back to not working!!!
Don’t know what happened but cannot get it to repeat!


Your post got me hopeful, tried mine but still nothing…. Even did a reboot, re launch, re start, re everything!!! This is BS for the long haul……


Yeah, it worked once - got my hopes up that it had been fixed, then wouldn’t work again.

I have the same issue. Connects fine on wifi but not on Verizon Cellular. It used to work when I first got the doorbell but stopped maybe a month ago. I’m guessing an update broke it and hopefully they will get it fixed soon.

geez - you’d think this would be high priority. Did you file a support request / log?

I did. And did a second one last week. That is why I am about to take this doorbell down. They have not supported their own device and not even contacted me about any of it. I feel SOL about it. Just sucks that all the other devices work fine.


I too have the same issue. iPhone 13 on Verizon. Wife’s phone works fine. iPhone 12 on Verizon. Could it be a 5G thing? Mine worked fine till last firmware update.